User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Done Timing Belt 19 cti now engine light on?

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Done Timing Belt 19 cti now engine light on?

    Done my timing belt today as per the excellent how to, also water pump, all went well, I started it up with the air box still removed, it started ok but engine light came on? put it down to missing airbox so re fitted it but light is still on? anyone know what the problem might be? this will bug me overnight! too dark now to mess with it!

    thanks for any advice

    Ronnie

  2. #2
    Regular Member vmb2722's Avatar
    Join Date
    May 2012
    Location
    Blackpool/St Mary's Bay
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusiv

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    did you reconnect the MAF?

  3. #3
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    58 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Was the MAF also unplugged?

    Try disconnecting battery for 15 mins

  4. #4
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by vmb2722 View Post
    did you reconnect the MAF?
    Yes made sure that was on, nothing else was unplugged so it seems strange?

    thanks Ronnie

  5. #5
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Critch View Post
    Was the MAF also unplugged?

    Try disconnecting battery for 15 mins
    cheers will go that a try in the morning

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    All fixed now, was staying on due to the airbox being off, had to reset the fault code

    cheers Ronnie

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. anyway to do the timing belt without timing tool
    By valvelift in forum Engine & Drivetrain
    Replies: 16
    Last Post: 15th December 2012, 18:47
  2. Timing belt failure/knackered engine???
    By 123rado in forum Engine & Drivetrain
    Replies: 61
    Last Post: 15th December 2012, 18:35
  3. Engine noise louder than it was before timing belt was replaced
    By the-converter in forum Engine & Drivetrain
    Replies: 2
    Last Post: 14th October 2011, 12:26
  4. Timing belt.. 1.8 petrol engine
    By waterbourne in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 10th May 2011, 21:05
  5. timing belt kit
    By Rapala in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 28th December 2008, 15:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •