User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Help needed alternator

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    northamtponshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help needed alternator

    Hi there just a quick question.
    Was driving home last night in pointing rain when battery light came on. Got home (40miles later) And car was a bit sluggish starting. Fearing it was an alternator fault I ordered one that turned up today. Gone over to parents to fit it but car turned over first time, battery light stayed off over 15 mile journey. Stuck the multimeter on it and it's holding 12.8v with engine off, with engine running with no load on at idle it's charging at around 13.8v and with lights and heating on etc it's charging at 13.4v. Are these figures what I should be expecting or are they low? If they are low ill change the alternator if they are ok then it's going back and I'll have my £160 back.
    Its on a 57 plate 1.9 cdti Sri 150bhp

  2. #2
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Chances are light will come on again, happened to me too, light came on but only went off for a few mins

    Ronnie

  3. #3
    Regular Member wildchild's Avatar
    Join Date
    Sep 2011
    Location
    west-mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : elite

    Engine : 1.9 cdti 16v 150

    Year : 06

    Mileage : 111250

    Default

    Iirc i think it should charge at 14.4-5ish whilst running if you got cd70 head unit hold down settings n wait for the bong and its saying testmode on. then press bc button until you come to a screen displaying thr voltage let it idle with no load ie heating lihts music n see what its running at as said should be roughly 14+ n when you finished press main then hold settings again n wait for bong anything less could me alternator on way out.
    But another thought is have you got a undertray on if not. you belt could have been soaked n slipping hth
    gaz

  4. #4
    Regular Member
    Join Date
    Sep 2010
    Location
    northamtponshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well light has stayed off so far, will keep hhold of new alternator over the weekend. Not sure what head unit I have. Think it's cd30. Just has trip, avg mpg etc.
    with engine revving at 2000rpm it was at 13.8-14v

  5. #5
    Regular Member wildchild's Avatar
    Join Date
    Sep 2011
    Location
    west-mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : elite

    Engine : 1.9 cdti 16v 150

    Year : 06

    Mileage : 111250

    Default

    I think thats a bit low for revs that high should be 14+ at idle 850 rpm.
    gaz

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice needed please - is my alternator on its way out?
    By dae36 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 1st February 2013, 12:14
  2. help needed trying to fit alternator belt
    By matts1185 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 27th November 2012, 19:30
  3. Possible Alternator... Advice needed.
    By AndyT23 in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 29th August 2012, 10:24
  4. Urgent alternator help needed!!
    By simmo3187 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 23rd June 2011, 11:24
  5. HELP NEEDED alternator for 1999 2.0i vectra
    By jimbob78 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 12th September 2009, 20:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •