User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Z22SE Lumpy Idle

  1. #1
    Regular Member
    Join Date
    Jan 2011
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Z22SE Lumpy Idle

    Hi guys,

    Have changed the CTS and lambda sensor.

    Car starts fine when the engine is cold. However, when the engine is at operating temperature if I switch it off and on again within 5-15 minutes, it struggles to start and fires up weakly.

    Any ideas?

  2. #2
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi 150 Hatch

    Trim : SRi

    Engine : Z19DTH

    Year : 2008

    Mileage : 69'000

    Default

    This sounds like a similar problem I recently corrected with my mates astra 2.2, it was a stuck EGR valve, caused poor idle and running, struggled to start etc. I replaced it with a good second hand unit and blanked it off at the same time, its much better now.

  3. #3
    Regular Member
    Join Date
    Jan 2011
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Good point! I had forgotten about the EGR. I think I'll get the cheater for it and blank it off.

    This bit confuses me though. Does the EGR have to working correctly before I remove it and blank it off? Or can I just remove a faulty EGR, fit the cheater and blank it off?

  4. #4
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    Don't need the cheater, just black it... That's what I've done, still needs to stay connected.

  5. #5
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi 150 Hatch

    Trim : SRi

    Engine : Z19DTH

    Year : 2008

    Mileage : 69'000

    Default

    The cheater is not needed, I cut a blanking plate from a piece of alloy plate, bolted the egr off to the side so its still connected but not doing anything as such, the valve does need to be working correctly though or the problems will still be there.

  6. #6
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    If the EGR is working properly they you can do without the cheater, but if the EGR isn't working properly then you need the cheater, although the car should run better but you may get an emissions light on the dash.

    To check the EGR unbolt it and pass 12v over pins A&E, this is my working EGR.

    Last edited by rushy; 26th August 2012 at 21:38.

  7. #7
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi 150 Hatch

    Trim : SRi

    Engine : Z19DTH

    Year : 2008

    Mileage : 69'000

    Default

    With the symptoms the thread starter has described I'm guessing its not working correctly, my mates was working to some degree but not well enough, it would some times stick when tested in the manor of your video, the replacement was much better though and no lights on the dash.

  8. #8
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    The Cheater is only £10, and its a donation to a Forum so if the EGR is duff I'd just bang a Cheater on there rather than replace TBH, VX don't replace, they blank and Tech 2 it out.

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for all the info guys. Cheater and blanking plate purchased, can't wait for them to arrive. One less problem to worry about.

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Don't forget to unbolt and give the tb a real good clean as the 2.2 has no icv, the butterfly controls the idle so and dirt build up affects a smooth idle. This won't be the cause of all your symptoms but it'll help it along.

    Sent from my Nexus 7 using Forum Runner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.0t edition 100 lumpy idle
    By 6009tristanb in forum Engine & Drivetrain
    Replies: 18
    Last Post: 4th January 2012, 17:02
  2. lumpy idle on a 2.2(z22se)
    By denzilbud in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 28th July 2009, 15:13
  3. Lumpy idle on 2.2 Direct SRi
    By Palmo in forum Engine & Drivetrain
    Replies: 47
    Last Post: 22nd January 2009, 18:53
  4. lumpy idle
    By old cruiser in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 24th November 2008, 20:39
  5. 3.2 v6 Lumpy idle!?!
    By byebyeitsagsi in forum Engine & Drivetrain
    Replies: 20
    Last Post: 13th August 2008, 12:24

Visitors found this page by searching for:

Z22SE IDLE SENSOR

z22se lumpy idle

egr stuck z22se

z22se idle

egr blanking plate for vectra c z 22 se

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •