User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Poor fm signal

  1. #1
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Poor fm signal

    Hi all just wondered if anyone has a link to an fm booster for the cd navi 70 ? The signal sometimes fades and sound quality goes quiet.have read on tinterweb that you can buy signal boosters but would like a tried and tested one from you guys first please if possible,thanks,carl.
    Car is 2007 vectra cdti 150 with cd navi 70.

  2. #2
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Meriva B

    Trim : SE

    Engine : 1.7CDTi

    Year : 2011

    Default

    Before spending money, I would suggest that you 1st remove the aerial and clean the brass thread as best you can, then refit with a dab of grease on (only) the rubber bit to help seal it and keep the weather out. There will also be an aerial connection below the aerial and above the headlining, but you will need to drop the headlining to check it.
    Removing and re-connecting electrical connections is usually worth a go to sort problems.

  3. #3
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nice one mate i will have a go at aeriel then first and see if it improves,if not then try dropping headliner.i have read on the net of problems with the cd navi 70 tho.

  4. #4
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just checked aeriel and is as clean as yor nans hat so dont think its down to that,any other folks had this issue and used a signal booster ?

  5. #5
    Regular Member Craig1985's Avatar
    Join Date
    Dec 2007
    Location
    harwich essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm having the very same problem with my cd70 all connections are fine tho

  6. #6
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its a pain mate when listening to radio.may try a local ice shop see what they suggest.

  7. #7
    Regular Member dilan's Avatar
    Join Date
    Aug 2009
    Location
    dudley, west midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If any consolation, I have cd70 navi and my fm reception is shocking, I tend to listen only to CDs cos it's so poor..

    Sent from my iPhone using Forum Runner

  8. #8
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My CD70 also has poor FM reception, although it might be where i live?

  9. #9
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well ive just moved house and thought its cause im slightly in the sticks till i took a neighbours car to work to repair it,i work in a bodyshop,and that cars reception was bang on,then i used one of our courtesy cars from work and that was fine too.when i googled it someone had posted on an astra forum i think and had a link to a fm booster but was back in 2008 so the link had expired.there is one on radioshack on ebay but its for seat vw audi,its says vectra also but not too sure if it works so was after someone who has tried one.

  10. #10
    New Member
    Join Date
    Sep 2013
    Location
    blackpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : Hatchback

    Engine : 1.8

    Year : 2007

    Default

    Hi everybody, My wife is also having problems with the cd30 fitted to her 57 plate Vectra it will change channel on it's own and our local station is just 1/4 of a mile from where we live, I changed the antenna for a secondhand one off ebay but it's still the same, how does the amplifier get it's power I know there is a blue wire coming from the base of the antenna but where is it fed from, also I bought an amplifier from ebay and yhe fittings where wrong, the listing was for a Vectra 2004>but the connecting parts are too big can anybody help

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. where can i get an RPM signal?
    By Caveman_nige in forum Electrical & ICE (including SatNav)
    Replies: 29
    Last Post: 21st October 2011, 18:00
  2. Poor radio signal Vectra C
    By Haza1981 in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 28th June 2011, 19:18
  3. Attention T-mobile Customers With Poor Signal;
    By ChrisBilly in forum General Chat
    Replies: 20
    Last Post: 15th October 2010, 04:17
  4. GPS signal
    By bigmac in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 21st April 2010, 20:07
  5. No GPS signal For Sat Nav
    By steve74 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 28th July 2007, 22:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •