User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 2.0DTI Y20DTH Crankshaft Sensor & Metal Shavings

  1. #1
    Regular Member
    Join Date
    Jul 2010
    Location
    Swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : LS

    Engine : 2.0DTI

    Year : 2002

    Mileage : 165000

    Default 2.0DTI Y20DTH Crankshaft Sensor & Metal Shavings

    Hello,
    I have just finished cleaning my cranksaft sensor on the above engine and found loads of metal shavings all over the inside of it.

    Anyone have any ideas what they are from and what needs changing :/ im expecting the worse. My clutch makes a horrible noise when lifting up but not when fully pressed down.

    Thank you all.

  2. #2
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Its very unlikely to be related to your clutch noise,i'd drop the oil and see if there is any swarf in the oil or on the sump plug as some are magnetic.

  3. #3
    Regular Member
    Join Date
    Jul 2010
    Location
    Swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : LS

    Engine : 2.0DTI

    Year : 2002

    Mileage : 165000

    Default

    Quote Originally Posted by macdad View Post
    Its very unlikely to be related to your clutch noise,i'd drop the oil and see if there is any swarf in the oil or on the sump plug as some are magnetic.
    I have not long had a full service including new oil from a reputable garage is this problem common? I have read it could be the flywheel grinding down.

    Thanks

  4. #4
    Regular Member
    Join Date
    Jul 2010
    Location
    Swansea
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : LS

    Engine : 2.0DTI

    Year : 2002

    Mileage : 165000

    Default

    Is it possible for a damaged or worn clutch to cause this?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Y20DTH Boost Sensor
    By colreid in forum Engine & Drivetrain
    Replies: 12
    Last Post: 22nd November 2012, 19:39
  2. 2.0dti y20dth throttle
    By chris70 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 24th August 2011, 08:07
  3. Engine Problems 2.0DTi Y20DTH
    By Daniel89 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 16th August 2011, 19:10
  4. 2.0Dti (Y20DTH) almost stalling - intermittent
    By MatB in forum Engine & Drivetrain
    Replies: 7
    Last Post: 7th June 2011, 17:45
  5. timing chain rattle then slip 2.0dti y20dth engine
    By bran.c in forum Engine & Drivetrain
    Replies: 24
    Last Post: 20th April 2011, 21:53

Visitors found this page by searching for:

vectra c 2.0 dti crankshaft sensor

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •