User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: heater blower problems

  1. #1
    New Member
    Join Date
    Jun 2012
    Location
    norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default heater blower problems

    please help, i have had a problem with my fan/blower not working on settings 1,2,3 so i replced the little unit that controls the speed (resistor pack i think) that worked for about 10 mins and got so hot and burnt out, i was told the fan itself needed replacment which i did with a new resistor pack, i replaced these again worked for 10mins and burnt the resistor pack out, dont no what else to try.

  2. #2
    Regular Member
    Join Date
    Jan 2012
    Location
    Silverstone village
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the pollen filter that it isn't blocked ?

  3. #3
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    33 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    Water getting in?

    Confirmed power an ground is ok?

  4. #4
    New Member
    Join Date
    Jun 2012
    Location
    norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i asume the pollen filter has been change as i requested at the last service a month ago so i think it's ok, there is no water getting in and i think the power is ok as it works ok on setting 4.

  5. #5
    Regular Member
    Join Date
    Dec 2009
    Location
    exeter
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    dont asume that . i had a service and they said it was done and i had a choked up filter which was causing the problem

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Major heater blower problems!!!!!
    By Carper31 in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 6th December 2012, 02:28
  2. heater blower not doing its job
    By coylo5 in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 22nd February 2012, 14:58
  3. heater blower
    By bootneck85 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 18th April 2011, 00:40
  4. Heater blower!!!!!
    By mitch in forum Electrical & ICE (including SatNav)
    Replies: 14
    Last Post: 19th November 2010, 00:15
  5. Heater blower resistor problems
    By wildtrout in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 4th July 2010, 16:20

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •