User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: battery or alternator?

  1. #1
    Regular Member Swedge's Avatar
    Join Date
    Jul 2012
    Location
    Scottish borders
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default battery or alternator?

    went to start the car today 1.9cdti 16v and it just clicked

    jump started it and it was fine but lights were dim inside and the p/s light came on

    battery light isnt on though?

    its only getting about 9v on the terminals when running

    how do i figure out if its the battery or the alternator?

  2. #2
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    If the battery is goosed you should still get 14.4v at the terminals with the engine running. Looks like the alternator at fault. If your a member of the AA etc they should be able to test your battery when they come out too.

  3. #3
    Regular Member Swedge's Avatar
    Join Date
    Jul 2012
    Location
    Scottish borders
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like the alternator then, just called my local parts and they said they have different amperage alternators?

    90-105-125

    will it matter what one? mines is a denso one

  4. #4
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Not sure about that, but id have thought you should be able to put on the higher amperage one.

  5. #5
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mk1 renault scenic... I know I know but it drives

    Trim : Basic

    Engine : 1.6 16v

    Year : 2003

    Default

    What's battery voltage before engine running?

    I suggest charging or changing battery before fitting new alternator.

    As it could shorten the life of new alt trying to charge a dead batt

  6. #6
    Regular Member Swedge's Avatar
    Join Date
    Jul 2012
    Location
    Scottish borders
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    alternator is off and its being collected tomorrow with another being dropped off

  7. #7
    Regular Member Swedge's Avatar
    Join Date
    Jul 2012
    Location
    Scottish borders
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    New alternator fitted and running fine

  8. #8
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    36 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    Did you put the higher amperage one on?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Alternator or Battery
    By Jamie in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 21st December 2011, 21:30
  2. Help With Battery/Alternator
    By Ultim8 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 27th May 2011, 14:37
  3. Battery, alternator or something else?
    By djr69uk in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 6th December 2010, 16:19
  4. Alternator or battery?
    By RobW in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 29th November 2010, 22:20
  5. Alternator or Battery?
    By callist in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 4th October 2010, 20:24

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •