User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Possible Alternator... Advice needed.

  1. #1
    AndyT23
    Guest

    Default Possible Alternator... Advice needed.

    Hello All,

    Very new member, only just picked up my car on Fri. It is a 2005 54 plate Vectra Estate 1.9CDTi 150 Elite.

    I have noticed that the car is a little sluggish in starting and the diplay screen dims as the engine turns. I popped onto here and read the scarily high number of threads relating to similar issues.

    My question is have I got a car in the early stages of alternator failure?

    I am getting 12.3v from the battery this morning before turning the car over. Taking readings as the engine is turned over gives a voltage dip down to less than 10v. Readings taken as the engine idles is giving 13.8v with no load. Turning on the heated seats, lights, radio, blowers etc drops the voltage to a slightly fluctuating 12.7v to 12.9v

    I have a 2 month/2000 mile parts only warranty from the supplying dealer so I am wondering whether it should be going back to them or not.

    Any further help/advice/recommendations will be much appreciated.

    Thanks in advance guys.

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Alternator going by sounds of it. One of diodes in diode pack has failed. Thats why in cannot cope with the load

    But not helped by the battery not being to healthy either

  3. #3
    Regular Member Mr Owens's Avatar
    Join Date
    Jun 2012
    Location
    Wickford
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    The battery needs fully charging to start with it should read 12.6v minimum when running the alernator should charge between 13.5-14.5v any lower than that and it's not going to fully charge the battery

  4. #4
    AndyT23
    Guest

    Default

    Thanks for the advice.

    Quick update! I have changed the battery as I discovered it was the original battery and well past it's best. The car now starts fine and is behaving as expected. I do still have my doubts about the alternator and agree with previous post from Critch so I will be checking the voltages for this again as soon as I get a few spare mins. Also with the bonnet up and the engine running I am getting some slight chirping noise from the vicinity of the alternator so I am thinking I will start collecting the bits together ready to change the alternator and all associated parts so I can be happy that all is as good as it can be.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Advice needed please - is my alternator on its way out?
    By dae36 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 1st February 2013, 12:14
  2. help needed trying to fit alternator belt
    By matts1185 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 27th November 2012, 19:30
  3. Help needed alternator
    By babilon2 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 30th August 2012, 21:55
  4. Urgent alternator help needed!!
    By simmo3187 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 23rd June 2011, 11:24
  5. HELP NEEDED alternator for 1999 2.0i vectra
    By jimbob78 in forum Troubleshooting
    Replies: 0
    Last Post: 12th September 2009, 20:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •