User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Passanger and rear electrical windows don't work

  1. #1
    Regular Member
    Join Date
    Aug 2012
    Location
    T
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Passanger and rear electrical windows don't work

    Hi

    Both rear and passenger window worked one week ago but now they don't. When using drivers switch all windows work fine.
    I tried with windows lock on/off but nothing.

    Are there any other ways these switches are blocked?

    Thanks in advance!

  2. #2
    Full Member neverlandandy's Avatar
    Join Date
    Sep 2006
    Location
    lanark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Elite Nav

    Trim : Elite

    Engine : 2.0 cdti

    Year : 2012

    Mileage : 9k

    Default

    just a daft question are you sure the slider is set to the rear window when trying it from the drivers door switch as that once happened to me and i thought mine were knackered

  3. #3
    Regular Member
    Join Date
    Aug 2012
    Location
    T
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by neverlandandy View Post
    just a daft question are you sure the slider is set to the rear window when trying it from the drivers door switch as that once happened to me and i thought mine were knackered
    Driver's door switch is working fine, except that rear left window doesn't work with driver's switch. All other windows work fine with it.

    Situation:
    1. With drivers switch all windows work except one rear window.
    2. Passenger window doesn't work with passenger switch and same with the rear one's.

  4. #4
    Regular Member 06sri's Avatar
    Join Date
    May 2012
    Location
    northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    this seems to be a common fault with the passenger side switch, it can just stop working, i had this problem my self with the passenger switch, did not have rear electric so cant comment on them.

    the switch is faulty, you can remove it (carefully) and try to clean the contacts etc with the correct type of cleaner and see if that fixes it, if not then ebay for window swicthes, im quite confident its the switches at fault and not any other problems, out of interest does your passenger door speaker and mirror still work?

  5. #5
    Regular Member biffbangpow's Avatar
    Join Date
    Jul 2012
    Location
    ferryhill
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : gsi

    Engine : 3.2

    Year : 02

    Mileage : 96k

    Default

    check the door loom , mate had this on hes elite !

  6. #6
    Regular Member
    Join Date
    Aug 2012
    Location
    T
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by 06sri View Post
    this seems to be a common fault with the passenger side switch, it can just stop working, i had this problem my self with the passenger switch, did not have rear electric so cant comment on them.

    the switch is faulty, you can remove it (carefully) and try to clean the contacts etc with the correct type of cleaner and see if that fixes it, if not then ebay for window swicthes, im quite confident its the switches at fault and not any other problems, out of interest does your passenger door speaker and mirror still work?
    I am going to clean the contacts, what you suggest for cleaning? Will vodka 40% will do the work?
    Speakers and mirror are working for passanger side but rear tweeters and 1 speaker don't work.

  7. #7
    Regular Member
    Join Date
    Aug 2012
    Location
    T
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by biffbangpow View Post
    check the door loom , mate had this on hes elite !
    Did he check for wires not been damaged?

  8. #8
    Regular Member biffbangpow's Avatar
    Join Date
    Jul 2012
    Location
    ferryhill
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : gsi

    Engine : 3.2

    Year : 02

    Mileage : 96k

    Default

    Quote Originally Posted by matt89 View Post
    Did he check for wires not been damaged?
    yes , and they were several broken ones , pull the rubber boot out the door and inspect the wires

  9. #9
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    Quote Originally Posted by biffbangpow View Post
    yes , and they were several broken ones , pull the rubber boot out the door and inspect the wires
    several would be an understatement , only had 3 that weren't broken on my o/s/r door , had 4 broken on n/s/r door .

    was also getting the check safeguard messages on the dash up until I repaired both sides .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 13
    Last Post: 11th December 2010, 23:37
  2. Does Insignia Windows Operation via Keyfob still work ?
    By 67688c in forum Insignia car chat
    Replies: 11
    Last Post: 31st May 2009, 15:35
  3. Rear electrical centre
    By Geoshaw in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 21st November 2006, 23:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •