User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Ford Ka - hot air coming from vents on all settings

  1. #1
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default Ford Ka - hot air coming from vents on all settings

    My ole mum has one of these Ford Ka things.. Its a pile of you know what but its hers and i am now charged with keeping it running...

    Its an 05 plate with a 1.3 engine.. Its basic and does not have a temp gauge on the dash. In the cabin the blowers only blow out hot air. I topped the coolant up a week ago and it has not gone down since... I can hold the throttle open and get the fan to kick in.

    Does anybody have any ideas as to what the cause of this hot air on all the cold settings could be? Is it the thermostat?

  2. #2
    Forum Moderator soulman's Avatar
    Join Date
    Sep 2006
    Location
    VOTING UKIP IN AVELEY
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    14 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Astra Twin Top

    Engine : 1.9cdti

    Year : 07

    Default

    she hasn't got it set on recirc has she ?

  3. #3
    Regular Member rjw's Avatar
    Join Date
    Oct 2010
    Location
    cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    On the ka's the cold setting only reduce the air temperature by a low amount on models with no air con, so if the air temp is higher, the cold blower stays warm

  4. #4
    Regular Member Chris B's Avatar
    Join Date
    Jan 2012
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've had this issue and replaced the heater control valve twice - cos some ford forum post told me too!

    http://www.ebay.co.uk/itm/HEATER-CON...item19d1c55c8b

    But she still cooked the occupants!

    I then replaced the actual control panel and that fixed it properly!

    http://www.ebay.co.uk/sch/i.html?LH_...Model=Ka&rt=nc
    Last edited by Chris B; 8th August 2012 at 19:51.

  5. #5
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Its probably the heater control valve - located in the front scuttle tray - if you follow the heater hoses that leave the engine block where the go into the bulkhead you will find the valve - the two pipes go into the valve and come out the other side into two more hoses that go into the heater matrix in the cabin - the hoses are all held on with hose clips just disconnect them disconnect the electrical connection and pull it out - easy enough to do - its the same on older Fiestas and the valve fits both models. They usually fail open or closed leaving you with hot air or cold air only This is one but check your ma's year and model http://www.ebay.co.uk/itm/Ford-Fiest...ht_2457wt_1271

  6. #6
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    I have been looking more to the heater control valve as it appears to be a common point of failure on these, I also did read elsewhere that the panel can also be faulty on 1 in 20 cars and needs to be replaced..

    I reckon I may start with the valve as you did as its cheaper and then try the control if it persists..

  7. #7
    Regular Member Chris B's Avatar
    Join Date
    Jan 2012
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep that was my method too - BUT if you do happen to buy a contol panel dont worry about the facia colour, just get the correct buttons etc, the actual coloured facia can be swapped for the original one!

  8. #8
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    thanks.. handy tip, i thought that may be the case..

  9. #9
    Regular Member Chris B's Avatar
    Join Date
    Jan 2012
    Location
    Essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Caveman_nige View Post
    thanks.. handy tip, i thought that may be the case..
    Lol, I didn't know and they wife drove round with a silver one (rest is graphite) for months..........

  10. #10
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    finally fitted this part today and it fixed it.. what pita to it though..

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. face lift chrome vents and rear vents
    By simon1 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 21st December 2011, 21:13
  2. very little air coming out of vents
    By reeseandellie in forum Vectra C / Signum Car Chat
    Replies: 23
    Last Post: 9th December 2009, 16:54
  3. smoke/dust coming from air vents
    By adfrodsham in forum Bodywork & Interior
    Replies: 19
    Last Post: 16th May 2009, 14:41
  4. NAT settings
    By Guyver1 in forum Games Room
    Replies: 3
    Last Post: 26th March 2009, 11:36
  5. Why ford drivers should stay ford drivers
    By DAVO in forum Comedy & Humour
    Replies: 45
    Last Post: 10th February 2008, 19:56

Visitors found this page by searching for:

my ford ka is only blowing hot air

hot air coming out of vent in ford ka

ford ka cold air vent

Ford ka hot air

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •