User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Oil Sensor o-ring leaking. Advice please.

  1. #1
    New Member Murdoch Troon's Avatar
    Join Date
    Jul 2012
    Location
    Brisbane
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Oil Sensor o-ring leaking. Advice please.

    Hi

    Just collected our Vectra from it's 105,000km service. Since it's out of warranty, I am servicing at a local specialist as opposed to using the sharks at the main dealer. As a reminder, ours is a 3.2 V6 with Auto box.

    I've noticed a small oil leak, and they've diagnosed a dodgyh o-ring sensor on the base of the sump. Apparently the sump has to be dropped, and the seal replaced from the inside.

    Just want to confirm that this is indeed the case. I have a quote for 4 hours labour, plus the part.

    They also suspect that the front and rear rocker cover gaskets are seaping and want to do these when they do the cam belt, in another 15,000km.

    My second query is this. I seem to be having an inordinate amount of issues with oil leaks. I've just had one done on the gearbox, and now there are 3 new ones as described above. Is this normal? Bear in mind that this car has a full dealer service history for the first 100,000km of its life. That's just over 60,000 miles! Am I therefore bound for a life of issues with this car?

    Any thoughts?

  2. #2
    Regular Member
    Join Date
    Dec 2007
    Location
    Perth, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I actually just did this myself over the weekend. Not 4hrs work I can tell you that.

    Took me around 2 hrs all up I'd say. Unplug sensors, remove all sump bolts (torx bolts surrounding and also 4 hex bolts), lever the sump off from the front right (looking at the engine bay) using a screwdriver. Once off, pop the E clip off the sensor from the front of the sump and push the sensor into the sump, you'll see the orange o-ring seal has 'flattened'. Replace this and clean surfaces before pushing back in, it should have more resistance with the new seal.

    Clean both surfaces of the sump and engine before re-applying sealant. Permatex Black is what I used and works well. Finger tighten all sump bolts and leave for an hour before torquing up to 10ft/pounds. Hex bolts @ 40ft/pounds.

    Hope this helps!

    I still have an oil leak but looks to be from rear of engine, most probably rocker cover. You need to make sure the oil breather pipes are cleared out as blocked pipes can cause excess pressure and blow past the rocker seals.

    Pretty frustrating job to do the rocker covers as plenum needs removing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. rain sensor advice plz guys
    By rozzer2006 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 24th December 2012, 18:24
  2. Rear Parking Sensor Advice
    By julian924s in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 24th August 2012, 16:51
  3. Replies: 3
    Last Post: 13th August 2012, 22:25
  4. injector no4 leaking.need advice asap
    By will2.0dti in forum Engine & Drivetrain
    Replies: 10
    Last Post: 8th July 2012, 13:13
  5. MAF SENSOR CLEANER SPRAY? Your advice please...
    By sparky71a in forum General Chat
    Replies: 14
    Last Post: 11th December 2008, 21:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •