User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Is there anything I can damage cleaning boost sensor?

  1. #1
    Regular Member marky2027's Avatar
    Join Date
    Jul 2007
    Location
    Northumberland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Is there anything I can damage cleaning boost sensor?

    I cleaned my boost sensor couple of weeks ago but just sprayed with carb cleaner as per the how 2. I dont think I got it as clean as I could have done. I didn't want to go too hard in case I damaged the metal part inside. I am going to have another go at it but wondered if I should use a brush or not. How easy is it to cause any damage?? Carb cleaner or isapropyl alcohol? Any thoughts?

  2. #2
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    I used an old toothbrush and brake/carb cleaner, just be careful and you shouldn't have any problems.

  3. #3
    Regular Member marky2027's Avatar
    Join Date
    Jul 2007
    Location
    Northumberland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Is it like a metal filament in the middle or are there any moving parts?

  4. #4
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    no moving parts but there is a filament type part in the middle, as long as you give it a gently scrub it shouldn't break.

  5. #5
    Regular Member marky2027's Avatar
    Join Date
    Jul 2007
    Location
    Northumberland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Well I took it off and soaked it in carb cleaner and agitated with a brush. There does seem to be a moving part. The yellow needle thingy moves towards the centre pin. I am presuming this is how it measures the boost. Anyway there was some gunk in between the centre part and the yellow pin so I gave that a good clean. I also cleaned the contacts of the sensor with some electrical contact cleaner. All seems OK after a short drive but the next few days will be the real test.

  6. #6
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Strange, sure nothing on mine moved, glad to hear the cleaning went well though.

  7. #7
    Regular Member marky2027's Avatar
    Join Date
    Jul 2007
    Location
    Northumberland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Neve'o View Post
    Strange, sure nothing on mine moved, glad to hear the cleaning went well though.
    Unless that's my whole problem of the stuttering . Can anyone confirm if this yellow needle thingy should move?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Best method of cleaning boost sensor
    By mutley-k666 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 2nd November 2012, 03:35
  2. car is slower after cleaning the boost sensor!?
    By IrishVectra in forum Engine & Drivetrain
    Replies: 12
    Last Post: 5th June 2012, 18:36
  3. Cleaning Boost Sensor, 1.9CDTi ????
    By mpc in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 8th July 2010, 23:11
  4. how 2 on cleaning preface boost sensor 3.0 v6 ?
    By signum03 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 4th March 2010, 18:09
  5. Car still got judder after cleaning egr + boost sensor.
    By bigpaw35 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 11th August 2009, 18:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •