User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Does the Vec C have a self check system...

  1. #1
    Regular Member Chunklamb's Avatar
    Join Date
    Jan 2012
    Location
    Milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 330D (13) Tourer 258 Auto & Signum 1.9 CDTI (07) 150 Auto

    Trim : M Sport and Design

    Engine : Z19DTH

    Year : 2007

    Mileage : 38100

    Default Does the Vec C have a self check system...

    ...on start up?

    I ask, because someone has mentioned that a failing battery can cause a fault to be flagged up as you start the car due to power drain... but then after the car has re-started or been run for a few minutes (without moving) the fault clears...?

    (Random fault with ABS/TCS)

  2. #2
    Regular Member hothatch's Avatar
    Join Date
    Mar 2009
    Location
    Nottingham, emec#7
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRI NAV

    Engine : 1.6T 180 ECOTEC

    Year : 2012

    Default

    I believe the vec does do a self test on startup, checks the system for errors.

  3. #3
    Regular Member rich r's Avatar
    Join Date
    Feb 2011
    Location
    Selby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes - like most cars built after 1996 or so, the ECU checks most sensors on startup for short circuits, open circuits and signals that are outside the expected range. Once the engine is running these checks continue for the sensors it's possible to do that with. The ECU also has a concept of 'pending faults' which are faults it's detected, but if they don't occur again within a certain number of engine starts or minutes of running, are considered to have been a one off and so it won't store a fault code.

    For example, on startup or during running you might get a camshaft sensor fault being detected because it's not producing a stream of pulses that look right, and this will put the engine into 'limp home mode', because it'll be using the crankshaft sensor to work out fuel injection timings which isn't as accurate as using the camshaft sensor. But if you switch off and start it again, and this time the pulses look good, it'll clear the warning light (though in this case, the fault code will stay stored).

    The ABS system also needs to see good signals from the wheel sensors, which will only happen when the wheels are turning, so it's possible to get fault lights that only come on (or go off) once the vehicle has moved a bit.

  4. #4
    Regular Member Chunklamb's Avatar
    Join Date
    Jan 2012
    Location
    Milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 330D (13) Tourer 258 Auto & Signum 1.9 CDTI (07) 150 Auto

    Trim : M Sport and Design

    Engine : Z19DTH

    Year : 2007

    Mileage : 38100

    Default

    So do you think it could be possible that a failing battery could cause a problem like that?

  5. #5
    Regular Member rich r's Avatar
    Join Date
    Feb 2011
    Location
    Selby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Certainly a failing battery can cause all kinds of weirdness. Not least not being able to start the car

  6. #6
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    Does the light come on again when moving

  7. #7
    Regular Member Chunklamb's Avatar
    Join Date
    Jan 2012
    Location
    Milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 330D (13) Tourer 258 Auto & Signum 1.9 CDTI (07) 150 Auto

    Trim : M Sport and Design

    Engine : Z19DTH

    Year : 2007

    Mileage : 38100

    Default

    No. It stays on for a little while but turns itself off.

  8. #8
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    It should come on with ignition do a system check and if all is well then go off. It will also do another when vehicle starts moving and if all is well will stay off until next time ignition is on.

  9. #9
    Regular Member
    Join Date
    Feb 2010
    Location
    Netherlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Can the faulty battery cause that this self test is skipped?

  10. #10
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    if the battery is failing it will cause all kinds of problems to show up , these cars are very sensitive to voltage drops .

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wheels refurbed, Check - Car Buffed and Polished, Check! !
    By messermitch in forum Quick Photo Album
    Replies: 6
    Last Post: 18th July 2012, 23:18
  2. Check control system
    By bertxuk in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 3rd May 2012, 10:09
  3. system check/aaaah!!
    By the-wizard in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 10th September 2011, 17:56
  4. Any one got how teo guide to check air con system?
    By warren77 in forum Heating, Ventilation & Air Conditioning (HVAC)
    Replies: 0
    Last Post: 26th August 2011, 21:03
  5. Anyone in North West with tech 2? to check SRS system.
    By sri andy in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 3rd December 2009, 19:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •