User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Power steering stopped working

  1. #1
    New Member
    Join Date
    Jul 2012
    Location
    Bulgaria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Power steering stopped working

    Hi,

    My power steering stopped working abruptly yesterday. I was using the car. It worked just fine. Stopped the engine for about 5min and after ignition the power steering was gone.

    The fault that the computer registered is the following:
    OP-COM 100219a - PC based diagnostic tool

    OP-COM - CAN Communication Window> 2008 (8)|Vectra-C / Signum|Vehicle|Vehicle DTC Information


    Read Info...

    Identifier: 0x0104
    Hardware number:24444336
    System name: EHPS GEN3 TRW
    Part Number:0
    Software version number: V21_
    System description: TRW 0300
    Alpha code:
    Code Index and version: 005 03
    ECU variant coding: 0x00000100


    Total number of fault codes: 1

    C1526 - Motor Malfunction
    (00) - Not present
    What do you recon will be the problem and how much might it cost me?

  2. #2
    Regular Member Envy's Avatar
    Join Date
    Jun 2010
    Location
    Welwyn Garden City
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi Nav

    Engine : 1.8 VVT

    Year : 2006

    Mileage : 130k

    Default

    Have you tired looking at the fluid level for the power steering first to see if its low. Might be wise to have a look but I suspect your motor has indeed failed.

    I don't know about exact costs but I know its expensive to replace. Some one will come along with the figures im sure.

    Sorry can't be of more help

  3. #3
    Regular Member
    Join Date
    Jan 2012
    Location
    Silverstone village
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hopefully its just failed communication to the power steering rack... , maybe worth checking connections to from the rack if you can get it on ramps/axle stands.

  4. #4
    New Member
    Join Date
    Jul 2012
    Location
    Bulgaria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi,

    I took it to the shop and the verdict was a new pump. I bought one from e-bay and replaced it. However now I have a working steering and two more fault codes. Any ideas on those?
    OP-COM 100219a - PC based diagnostic tool


    www.auto-diagnosis.bg

    OP-COM - CAN Communication Window> 2008 (8)|Vectra-C / Signum|Vehicle|Vehicle DTC Information


    Read Info...

    Identifier: 0x0104
    Hardware number:24444336
    System name: EHPS GEN3 TRW
    Part Number:0
    Software version number: V21_
    System description: TRW 0300
    Alpha code:
    Code Index and version: 008 03
    ECU variant coding: 0x00000000


    Total number of fault codes: 2

    C1531 - Steering Angle Sensor System Voltage Circuit High Current
    (0B) - Not present

    C1532 - Steering Angle Sensor Signal Circuit Open or High Voltage
    (05) - Present


  5. #5
    Regular Member kman247's Avatar
    Join Date
    Nov 2008
    Location
    milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the steering angle sensor in the CIM needs to be recalibrated

  6. #6
    New Member
    Join Date
    Jul 2012
    Location
    Bulgaria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have an OpCOM and the shop has something called KTS. Do you know if any of them can do the job? If its the OPCOM, do you know the procedure to do that? Or know a place I can look it up? Thanks!

  7. #7
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    I think it needs to be done via Tech2 and you need the security code from the donor vehicle IIRC

  8. #8
    Regular Member kman247's Avatar
    Join Date
    Nov 2008
    Location
    milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    OPcom can do it , if you go into the CIM module and programming you then need the security code and follow on screen instructions , I have done this a few times succesfully.

  9. #9
    New Member
    Join Date
    Jul 2012
    Location
    Bulgaria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    These errors are all from the EHPS, why do I need to reprogram the CIM, am I missing something? Sorry if I'm too inquisitive - it is an expensive car and I'm a bit scared of every operation I'm performing

  10. #10
    Regular Member kman247's Avatar
    Join Date
    Nov 2008
    Location
    milton keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Steering angle sensor is under the CIM. If you don't know what you are doing leave it to a pro. A little bit of knowledge can be dangerous

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CD70 - steering wheel button stopped working
    By Caveman_nige in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 31st May 2012, 10:41
  2. parking sensors and power sockets stopped working
    By charliepirate in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 29th July 2010, 13:37
  3. Steering Wheel Controls Stopped Working
    By Bethan39 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 3rd April 2009, 16:39
  4. Steering Wheel Controls, Stopped Working!
    By bigcarman79 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 4th February 2009, 18:10
  5. Power steering stopped working
    By Dean82 in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 6th July 2008, 21:12

Visitors found this page by searching for:

reprogramming reprogramming opel vectra c power steering with opcom

steering im vectra dont work

signum power steering stop working

Vauxhall DTC C1526-00

gm vectra steering pump codes

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •