User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: quick Q

  1. #1
    Regular Member andy76's Avatar
    Join Date
    Dec 2008
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : cdti 150

    Trim : sri

    Engine : z19dth

    Year : 2005

    Default quick Q

    can faulty injectors cause loss of oil,smoke,
    once again oil light on dash, checked no oil on dipstick, put half ltr in, went for drive came back oil half way on dipstick,
    one mechanic said 1700 for engine rebuild then another one said could be faulty injectors leaking fuel with oil thus burning, ,

    feel like gettin shut n gettin an st lol

  2. #2
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    If there was no oil on the dipstick when you first checked, the only put half a lt in, thats the reason its only showing halfway up the dipstick. It takes 1lt from the bottom of the dipstick to the top mark.

    BTW 1700 for a engine rebuild? I bet your mechanic doesn't drive a Vectra charging those sorts of prices.

  3. #3
    Regular Member andy76's Avatar
    Join Date
    Dec 2008
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : cdti 150

    Trim : sri

    Engine : z19dth

    Year : 2005

    Default

    only put that much in as it says theres no oil, put some in then it shows way more than ive put in, also been told to change the oil filter on top of engine as they get blocked,
    i just want a decent mechanic to help, 3 years this has been going on and spent loads and nothing is stopping it ....

  4. #4
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    Try a slightly thicker grade oil, works for me everytime.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quick help plz
    By messsy in forum Engine & Drivetrain
    Replies: 16
    Last Post: 4th July 2012, 23:06
  2. Replies: 7
    Last Post: 12th October 2011, 10:24
  3. Quick wash & Quick Mods
    By ilovetechno in forum Quick Photo Album
    Replies: 11
    Last Post: 3rd October 2011, 19:40
  4. Quick Question - Need a Quick Answer if Possible
    By RobW in forum Suspension, Wheels & Brakes
    Replies: 3
    Last Post: 8th February 2011, 23:55
  5. Quick Help
    By DarylAAS in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 25th October 2010, 11:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •