User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Intermitant ecu light on

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Intermitant ecu light on

    Hi guys a friend has just popped round with his 53 plate 1.8 with engine light on intermittently. Read the codes and it's showing p0170-11 fuel trim system rich, current fault. It also had stored fault code p0100-06 mass or volume air circuit low input but this code cleared and wouldn't re occur. Any ideas where to start guys

  2. #2
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Potential causes include a vacuum leak, unmetered air leaks, bad O2 sensor, oil contamination in MAF connector or O2 sensor connectors, defective MAF (Mass Air Flow) sensor
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  3. #3
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Previous P0100 refers to MAF so maybe a place to start followed by the O2 sensor on the top of the manifold
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  4. #4
    Regular Member
    Join Date
    Jun 2011
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I was thinking with the combo of both codes that it could be the air mass sensor as it was also only showing 5kg at idle which seams a little low to me. Was expecting more like 8-9kg to be honest?

  5. #5
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    I have had two 1.8xe engined cars.
    One threw up codes like your one intermittently for the MAF and it turned out to be the flexi pipe on the exhaust was split
    The second one needed a new MAF and O2 sensor as when the MAF goes it overfuels and burns out the O2 sensor. Also only get a genuine MAF as the ebay ones are poo
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  6. #6
    Regular Member
    Join Date
    Jun 2011
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does it have an up and down stream O2 sensor? If so I'm guessing you mean replace the upstream sensor?

  7. #7
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    Quote Originally Posted by sriandy View Post
    Does it have an up and down stream O2 sensor? If so I'm guessing you mean replace the upstream sensor?
    not sure which one it is but it sits on top of the manifold at the front. I would check the flexi pipe first tho
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  8. #8
    Regular Member
    Join Date
    Jun 2011
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If it's on the manifold that will be up stream of the cat then cheers. I will be checking it over better at the weekend hopefully in the dry as was to wet tonight to have a mooch, just a flying visit tonight

  9. #9
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Need to see live data.

    See what front an rear oxy sensors are saying/ doing

    Veiw long an short term fuel trims.

    If you have a multimeter you can confirm voltage at mad an ixy to see if their the same as what ecu thinks they are

  10. #10
    Regular Member
    Join Date
    Jun 2011
    Location
    wolverhampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I couldn't see any live data for the fuel trims mate. The oxy sensors seamed all ok and switching as they should.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. intermitant wiper
    By Kaikianjames in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th January 2013, 21:25
  2. Intermitant EML light driving me bonkers!!!
    By Mc naughty in forum Engine & Drivetrain
    Replies: 0
    Last Post: 27th February 2012, 18:24
  3. Indicator intermitant fault
    By Photog Dave in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 31st March 2011, 22:51
  4. intermitant rev and speedo
    By vectra-sri-jon in forum Vectra C / Signum Troubleshooting
    Replies: 4
    Last Post: 21st February 2008, 16:00

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •