User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: MaF problem. 2.2dti

  1. #1
    Regular Member fuzzyllogik's Avatar
    Join Date
    Apr 2012
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default MaF problem. 2.2dti

    it all started a couple of days ago when the engine went into limp mode on the motorway giving me the old spanner light, called RaC and fault diagnosed maf sensor, drove car home on limp but it got quite rough running and clouds of black smoke until I disconected the maf thendrove fine all be it very slowly, bought a new maf today but it hasnt fixed the limp mode and its still running rough hesitating and almost stalling sometimes with the maf conected... any ideas also noticed the other engine light bottom right of the dash has come on.

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Is the new MAF brand new or used? Is it genuine Bosch or a copy?

    Do you know what the fault codes are? They will help enormously in narrowing down the possible causes...

  3. #3
    Regular Member fuzzyllogik's Avatar
    Join Date
    Apr 2012
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by James24 View Post
    Is the new MAF brand new or used? Is it genuine Bosch or a copy?

    Do you know what the fault codes are? They will help enormously in narrowing down the possible causes...

    It was a brand new MAF. traced the fault back and it turns out it may not have been my MAF in the first place, my EGR valve is sticking and a boost hose has blown off so no onder MAF readings were way out :-( new EGR valve needed now. gerr

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Oh well. You can just re-secure the boost hose as long as it's not damaged. What about cleaning and lubricating the existing EGR? A new one is very expensive...

  5. #5
    Regular Member fuzzyllogik's Avatar
    Join Date
    Apr 2012
    Location
    Bristol
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    best quote for an EGR I've had so far is £180, Going to clean up the old one and hope ;-) at least that should buy me some time. Dam computers I'd have probably diagnosed and fixed the boost leak earlier if the computer hadnt stepped in gerrrr then my egr wouldnt have got ****ed by black smoke ah well.

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    EGR valves always get sooted up.It's just a question of how long it takes to do it, and what the result is - clean or replace.

  7. #7
    New Member
    Join Date
    Feb 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Limp home spanner on Signum 3.0 diesel

    I too encountered the infamous 'limp home' spanner this week (Signum 3.0 V6 diesel), and having read some of the threads on here I sensed I was going to be in for a huge bill from my main dealer. EGR valve £400, fitting £200 etc etc .... no thank you!!

    I feel so lucky that I was able to find a local independent mechanic - AV Autos in south london - who had been fully trained by vauxhall (he used to work for them then set up on his own) who had all the diagnostic kit and experience to get straight to the problem. It turns out that the EGR valve only needed a clean, but the real issues were low fuel pressure (he cleaned out the pipes and fitted a new fuel filter) and the ECU software on my car was about 4 revisions behind, and had not been updated to the version which included a fix for this problem. (It had had a full service at the main dealer only 6 months ago - I wonder why they didnt include that advice??)

    Anyway, long story short, the car is now running better than ever and the bill I got was a fraction of what i would have got at the dealer.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Starting problem 2.2DTi
    By Mogsy007 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 23rd August 2012, 13:24
  2. 2.2DTI SRI Exhaust Problem
    By Dazzy2006 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 4th February 2010, 14:54
  3. 2.2DTI Problem
    By Dazzy2006 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 13th January 2010, 20:50
  4. 2.2DTI Elite - Air Con problem???
    By martyn_bannister in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 29th June 2009, 21:20
  5. Confused 2.2DTI Problem
    By kraviz in forum Engine & Drivetrain
    Replies: 5
    Last Post: 4th April 2007, 06:57

Visitors found this page by searching for:

signum maf problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •