User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: No power in low revs vecrta 1.9 cdti sri

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default No power in low revs vecrta 1.9 cdti sri

    Having trouble with power in low revs, but as soon as revs hit 2k rpm it picks up.

    Ive reacently had fitted

    New egr valve

    2 new injectors

    Injector wire loom

    Battery

    Any common fault on these?

    Many thanks

  2. #2
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : very

    Engine : Z19DTH

    Year : Nosey

    Default

    A search first would have shown swirl valves and vacuum line leaks too.

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Quote Originally Posted by nutron View Post
    A search first would have shown swirl valves and vacuum line leaks too.


    Swirls. If the bar is off, search for my thread "CDTi 150 Swirl Bar"

    Mine's like a different car since the fix

  4. #4
    Regular Member Adam8220's Avatar
    Join Date
    Apr 2011
    Location
    Ripley, Derbyshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    if that s all ok check the intercooler and boost pipes for leaks. seem to be common too.
    those symptoms on mine were down to sticky egr valve though. check egr actuation with tech 2 and wiring to egr from ecu.
    clean off boost pressure sensor that usually helps

  5. #5
    On a Sabbatical
    Join Date
    May 2012
    Location
    chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 cdti 120 difficult to start and low power under 1500 revs
    By johninthetoon in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 29th September 2010, 07:46
  2. Signum 120 CDTi black smoke and loss of power @ low revs!!!!
    By siw8158 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 29th July 2010, 17:08
  3. no power at low revs cdti
    By brownlow39 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd May 2010, 19:39
  4. 1.9 cdti power loss at low revs
    By topdogs in forum Engine & Drivetrain
    Replies: 14
    Last Post: 27th January 2008, 03:56
  5. vecrta 2.2 needs more power
    By beefycol in forum Petrol Engine related
    Replies: 0
    Last Post: 28th November 2007, 21:30

Visitors found this page by searching for:

vectra c 1.9cdti loss of power at low revs

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •