User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: spanner and battery light on

  1. #1
    Regular Member
    Join Date
    Jul 2010
    Location
    perth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default spanner and battery light on

    hi got a problem today driving home and went to turn corner and lost power steering plus all lights on dash and vdu went off then on again stopped car switched off then started it again same again 5 mins later got home pluged in code reader and got fault code p0563 system voltage high input reset code but battery light and car with spanner still on checked battery has good charge so not battery any ideas what else it could be any info and help is much appreciated.

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    If the battery light is on, it's telling you the alternator isn't charging.

    Have you put a multimeter across the battery to see that approx 14.5 volts is present with the engine running?

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    When you say it has a good charge, what is the charge? As above, should be 14.5v with engine running and all electrics off. Does sound like a shafted alternator though

    ---Sent from my iPhone 4 using Forum Runner.

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Alternator is goosed

  5. #5
    Regular Member
    Join Date
    Jul 2010
    Location
    perth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    well went out today to test alternator with multimeter and battery drained empty so cant start car do u think getting used alternator is wise as cant afford new one this month (tax ,mot,parts for mot).

  6. #6
    Regular Member STICKY3.2's Avatar
    Join Date
    Jul 2010
    Location
    Hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Regulator/Diode pack in back of altenator has probably failed causing the battery to discharge, sorry mate sounds like a new altenator required.

  7. #7
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Not worth getting it reconditioned?

  8. #8
    Regular Member
    Join Date
    Jul 2010
    Location
    perth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers guys for your advise will be new one at end of month.

  9. #9
    Regular Member skidmark1's Avatar
    Join Date
    Sep 2010
    Location
    cornwall
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2.2 Direct

    Trim : SRI

    Engine : YH 2.2 petrol

    Year : 2006

    Mileage : 85000

    Default

    Quote Originally Posted by STICKY3.2 View Post
    Regulator/Diode pack in back of altenator has probably failed causing the battery to discharge, sorry mate sounds like a new altenator required.
    Is it not possible just to get the regulator/diode pack and fit that instead of replacing the whole alternator??

  10. #10
    Regular Member STICKY3.2's Avatar
    Join Date
    Jul 2010
    Location
    Hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by skidmark1 View Post
    Is it not possible just to get the regulator/diode pack and fit that instead of replacing the whole alternator??
    Not worth the hassle, there may be other issues causing the volt reg causing it to work under extra load, personally I'd go for a top quality exchange unit or new.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Battery & Spanner Light on.
    By ickleric in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 11th September 2011, 21:31
  2. battery light on along with spanner through car light
    By conny in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 24th May 2011, 13:45
  3. Battery light and car with spanner icon?
    By johnnyallen in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 22nd June 2010, 10:29
  4. Help..Clear spanner light by disconnecting battery?
    By marky2027 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 23rd April 2010, 13:01
  5. Spanner light after changing battery
    By gtr1000 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 10th December 2008, 21:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •