User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Air conditioning not working Vectra C 2.0 DTI 2002

  1. #1
    Regular Member
    Join Date
    Jun 2011
    Location
    YORK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Air conditioning not working Vectra C 2.0 DTI 2002

    Just got back from my holiday (1 week) and the air conditioning is not working.
    When I pressed the A/C button it used to make a slight hiss and then there would be a slight change in engine revs and blow ice cold air.
    The unit was replaced last year so im pretty sure it is full of gas especially as it was working so good.
    Now it does nothing as if the compressor is not kicking in any advice would be appreciated as at the moment I cannot afford any more bills.
    I am assuming that the compressor has gone or I read somewhere it maybe the switch on the compressor.
    Regards Rich

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What was replaced last year? Condenser? Compressor?

    There is a pressure switch that won't allow the aircon to run if the gas has run away.

    The lack of hissing (made by the gas) would indicate that the gas has made a dash for it. Get someone to switch the aircon on while you watch the compressor (engine running obviously). If the pressure switch is cutting it out, you'll see the clutch pop in and the compressor turn (look for the centre of the pulley wheel moving in towards the main body of the compressor and start to spin) when the aircon is switched on then pop back out (and stop turning) straight away when the pressure switch.

  3. #3
    Regular Member
    Join Date
    Jun 2011
    Location
    YORK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi thankyou for your quick reply, I had a bump in it last year and I know they replaced the rad, which is if im right the air conditioning condensor too??
    I do not know weather they replaced the compressor.
    What baffles me is I left it at one of them shuttle parks at manchester where I give them the keys, it was working ice cold when i left it now its knackered.

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The aircon condensor is the front of the 3 'radiators'. Intercooler in the middle and water at the back. If it's been working a good while since that was replaced, it probably isn't related.

    Something may just have stuck so you could try giving it a bit of time to sort itself out. The most common cause of a leak is a seal where the pipes join together drying out and letting the gas out. This is one of the reasons to use aircon regularly.

    Also try checking operation of the compressor as per my last post.

    If it does look like a gas leak, then take it to somewhere that has the equipment to trace and fix the leak. The usual 2 methods are a UV dye in the aircon gas or a special gas and a sniffer.

  5. #5
    Regular Member
    Join Date
    Jun 2011
    Location
    YORK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thankyou im just a bit baffled as to why it would lose all its gas over a week?? I feel as if its not powering up will try what you suggested, could you tell me where the compressor is located? Could it be the clutch if so how would I know that its gone?

    Also forgot to mention a week before I went away the aircon did stop working one day and a couple of presses on the switch and it started up, this happened when I was stuck in traffic and I realised it was blowing warm so I switched it on and off and there was no hiss and after a couple of attempts it started up. Would this give the indication the clutch was going??
    Last edited by richardkay007; 6th July 2012 at 17:24. Reason: update

  6. #6
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The aircon compressor is driven off the belt and is located in front of the engine and near the bottom - look for something that looks a bit like an alternator and has 2 think rubber hoses leading into it.

  7. #7
    Regular Member
    Join Date
    Jun 2011
    Location
    YORK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thankyou are these pumps prone to malfunctioning?? If so are they much to fit seen them on ebay pretty cheap.

  8. #8
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not on the DTi. Rule out the gas leak first as that's cheaper and easier...

  9. #9
    Regular Member
    Join Date
    Jun 2011
    Location
    YORK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi im pretty sure its out of gas. If its fully empty, would it indicate a leak? A leak in the system would gradually go over time but this was like overnight. Making me think something major is wrong?

  10. #10
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Another thing to check for is damage to the condenser - e.g. by a stone - as this would cause a rapid loss of gas.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 vectra c 2.0 DTI LS ecu help please!
    By hugheso in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 29th April 2012, 11:54
  2. Vectra C 2002 Y20DTH Remap DTI 2.0 2002
    By richardkay007 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 8th February 2012, 14:18
  3. Vectra Air Conditioning Valve....
    By markmcc in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 21st November 2009, 15:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •