User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: throttle position sensor error(1120&1122)

  1. #1
    New Member claudiu__'s Avatar
    Join Date
    Aug 2010
    Location
    Romania
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default throttle position sensor error(1120&1122)

    Hello everyone,
    I need help with a problem with my 2005 1.9cdti(dth) no mechanic(so far) knows how to solve.
    When driving on bumpy roads, where the car leans left-right, at very low rpm(1000-1100 in 1st gear, that's the fastest i dare drive on that kind of road), i get the ESP light on, and the engine revs to 1300-1400rpm. I get no response from the accelerator pedal, and the only solution is to turn the engine off, remove the key, then restart it(sometimes more than once).
    I've cleaned the pedal contacts, than replaced the pedal with a new one. I've been said the problem is with the UEC(replaced it with a borrowed one, everything ok for a few days, than the problem reapperead), then with the 2 connectors that are under the UEC or with some of the wires(checked the wires and the 2 large connectors, cleaned them, problem still there). Now they want me to buy a new pedal(a second one), and if that doesn't solve it, change the ECU.
    Considering the fault only comes on when the car moves in a specific way, i tend to think there's a problem with a connector or some of the wiring, but apparently there're all ok.
    Anybody else had this problem? Thanks!

  2. #2
    Regular Member
    Join Date
    Jan 2012
    Location
    Silverstone village
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I very much doubt it is the pedal if you already have had one replaced.

    I would first look at the connectors for the ABS , I'm assuming these are also used for the ESP control.

    This may well be the ESP ECU and is only shown when the wheel is shown to be skidding (when esp would kick in), might just kick in and detect it but not recover correctly.

    ESP will expect both front wheels to be moving within a tolerance of each other and if not the esp will kick.. , just the bumpy road gives the signs of a skidding wheel as they wouldn't be travelling at the same speed.

    Can you not just pull a fuse and turn it off?

  3. #3
    New Member claudiu__'s Avatar
    Join Date
    Aug 2010
    Location
    Romania
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Tried starting the car with the ABS/ESP ECU disconnected, but it won't start. I'll find the fuse later on and see what happens without it.
    When the problem is present, the ESP light(the triangle with the sliding car, that flickers when the car is skidding) stays on. But there's no dtc trouble code concerning the ESP/ABS ECU.Shouldn't there be a ESP/ABS error present? The only DTC codes i get are those in the title, 1122 and 1120.

  4. #4
    Regular Member Vectra Meldrew's Avatar
    Join Date
    Mar 2010
    Location
    Hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Exact same codes I'm getting and 1300 revs with no throttle response! However I don't have any ABS or ESP lights just the spanner light when It happens. Intermittent problem though, just comes and goes, not on bumpy roads.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. throttle position sensor
    By Ryan in forum Engine & Drivetrain
    Replies: 7
    Last Post: 24th November 2010, 21:06
  2. Throttle Position Sensor
    By RichyA in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 23rd September 2010, 15:12
  3. Throttle Position Sensor...
    By GazVXLINE170 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 16th September 2010, 20:51
  4. Throttle Position Sensor
    By Kristypie in forum Engine & Drivetrain
    Replies: 1
    Last Post: 9th April 2010, 21:14
  5. throttle position sensor
    By Morephun in forum Engine & Drivetrain
    Replies: 2
    Last Post: 3rd July 2008, 10:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •