User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Dexron III for my AF40 automatic gearbox?

  1. #1
    New Member
    Join Date
    Apr 2012
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Dexron III for my AF40 automatic gearbox?

    I went into euro car parts today to go and get some fluid for my AF40 autobox to start the process of flushing the transmission due to a shifting problem.

    They recommended to use Dexron III? I just thought id check with you guys if this is the correct fluid to use as I dont want to use the wrong fluid and ruin what is quite an expensive transmission!!

    If I believe correct the fluid that I am meant to use should be AW-1? is Dexron III the equivalent?

    What should I do?

    Thank you

  2. #2
    Regular Member blue estate's Avatar
    Join Date
    Feb 2008
    Location
    oh well.. I tried..
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    http://www.castrol.com/castrol/secti...tentId=7073092

    Put your reg in there and see what they suggest.. use this all the time at work

  3. #3
    New Member
    Join Date
    Apr 2012
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the response, I typed in the reg, but it says refer to main dealer? which I know say to use GM 93 165 147 but I need to do a transmission flush so I need quite a bit and I get discounts at ECP so worth a try for an alternative.

    By the way, your estate looks fab

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Af40 Gearbox Limp Mode ( again )
    By viper8 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 9th September 2012, 00:41
  2. Need an AF40 gearbox!
    By the_rocker in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 30th April 2012, 17:47
  3. Automatic Gearbox
    By delboy2028 in forum Engine & Drivetrain
    Replies: 9
    Last Post: 1st March 2011, 16:28
  4. Af40 auto gearbox loss of drive.
    By ricky1 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 3rd October 2010, 21:57

Visitors found this page by searching for:

vectra af40 auto box does not want to select drive when cold site:www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •