User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Brake creak

  1. #1
    Regular Member
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Brake creak

    I'm getting a right old creak when I press the brake pedal on my Vectra...it happens whether the car's moving or stationery, and with the engine running or with it off (have to press a bit harder on the pedal to make it happen with the engine off, obv.)

    I've removed the trim under the steering column to see if it's a return spring or something, and the noise doesn't seem to be coming from inside the car. I've had someone press the brake while I listened for noises from the calipers but nothing there either.

    I think it can only be coming from the master cylinder or the servo, but I'm a bit stuck for ideas on how to check this and resolve the problem.

    Has anyone had anything like this, or have any ideas?

    The brakes actually work very well BTW!

    Cheers.

  2. #2
    New Member
    Join Date
    Jul 2011
    Location
    Suffolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have exactly the same problem on my 2003 2.2dti SRi hatch. I'd be very interested to hear if anyone has found the cause of this problem.

  3. #3
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Are you sure its coming from the servo or master cylinder and not from one of the wheels - the servo is in a sealed unit that you can't get into - the master cylinder is just a small piston with rubber seals that moves in brake fluid and is unlikely to make a noise as it is in effect lubricated by the brake fluid. There is a pushrod that runs through the servo that pushes the piston in the master cylinder to operate the brakes as you apply pressure to the brake pedal. This rod connects to the brake pedal and it could be that that needs a bit of lube as well the return spring but from the sound of it you have already checked that. When you were looking at the return spring did you operate the pedal to replicate the noise?
    The noise could be coming from one of your brake calipers, usually one of the pads tight in the body of the caliper - if I would you I would be looking at checking each caliper/pads to make sure they are operating smoothly in the caliper.

  4. #4
    Regular Member
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well it seems I was wrong - the noise was coming from the calipers!

    To cut a long story short I've opened up the dust boot, pushed the piston out a bit and put some dry lube around it then carefully pressed it back in, and the noise is gone.

  5. #5
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Glad your sorted - were the pads worn - they sometimes get noisy if they are ready for replacing

  6. #6
    Regular Member
    Join Date
    Apr 2010
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The pads were pretty much brand new - I replaced them a few weeks ago along with the discs. Things were fine for about a fortnight then they started getting noisier and noisier until it was embarrassing!

    Cheers for the suggestions BTW.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Almighty CREAK!!!
    By JonV6 in forum Suspension, Wheels & Brakes
    Replies: 6
    Last Post: 25th December 2012, 14:56
  2. gsi creak
    By fletch123 in forum Bodywork & Interior
    Replies: 1
    Last Post: 6th May 2012, 16:00
  3. What the creak!!!
    By pix in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 26th June 2011, 01:32
  4. Gsi creak.....
    By david.aka.judas in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 21st May 2010, 20:42
  5. b pillar creak
    By ROB WOODHOUSE in forum Bodywork & Interior
    Replies: 7
    Last Post: 29th March 2006, 17:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •