User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Car labouring and lack of power

  1. #1
    New Member julesbland's Avatar
    Join Date
    Oct 2008
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Car labouring and lack of power

    Hi,
    I have a 1.8 Vectra C, today on the motorway the car struggled to accelerate up to speed and felt as if the engine was struggling to breathe. It shuddered going up inclines but was the opposite when going down hills. When home the front of the car was very warm but put this down to the car struggling. I did gey through some fuel, buy with noengine or management lights coming on its difficult to pinpoint the fault. Searching the net it points to the Cat but also the EGR valve. Can anyone help on this?
    Many thanks

  2. #2
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    have you checked that the turbo hose is not loose,

  3. #3
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Possible egr fault. But I would say should have given you a fault light.

    Is air filter ok? No restrictions or anything?

  4. #4
    New Member julesbland's Avatar
    Join Date
    Oct 2008
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by jonnybravo View Post
    have you checked that the turbo hose is not loose,
    Hi Jonnybravo
    My car is a non turbo version, been told it could be the EGR valve.
    Many thanks
    Jules

  5. #5
    New Member julesbland's Avatar
    Join Date
    Oct 2008
    Location
    Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Critch View Post
    Possible egr fault. But I would say should have given you a fault light.

    Is air filter ok? No restrictions or anything?
    Hi Critch,
    I have a K&N pannel filter and all clear, no fault light, but but it is pointing to a EGR valve
    Many thanks
    Jules

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 120 Lack of power.
    By carling in forum Engine & Drivetrain
    Replies: 3
    Last Post: 29th January 2013, 19:25
  2. Lack of power
    By McLovinH in forum Engine & Drivetrain
    Replies: 20
    Last Post: 23rd August 2012, 22:17
  3. lack of power
    By scottaa73 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 8th May 2012, 10:49
  4. Lack of Power
    By juggernaut in forum Engine & Drivetrain
    Replies: 10
    Last Post: 3rd April 2010, 16:20
  5. Lack of power
    By reptar in forum Engine & Drivetrain
    Replies: 6
    Last Post: 20th November 2009, 20:00

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •