User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Loss of power steering

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    Great Torrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Loss of power steering

    Have not got around to checking fluid level yet ,but i seem to lose power steering when braking hard or going very slow , any ideas before i take inner wheel arch out to get to fluid bottle , garage seem to think might be speed sensor

  2. #2
    Regular Member
    Join Date
    May 2012
    Location
    Great Torrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by scrivy View Post
    Have not got around to checking fluid level yet ,but i seem to lose power steering when braking hard or going very slow , any ideas before i take inner wheel arch out to get to fluid bottle , garage seem to think might be speed sensor
    Sorry meant to say i have a 2003 2.2 dti sri

  3. #3
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Alternator ?

  4. #4
    Regular Member
    Join Date
    May 2012
    Location
    Great Torrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thought about that , belt squeals a bit on start up , having new belt put on tomorrow, thanks

  5. #5
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    On the 1.9's its quite a common fault - the alternator starts to fail and one of the symptoms is the power steering fails intermittently. Usually get the p/steering warning light on the dash. Before you do anything get your battery and alternator checked out. Your belt squealing could be the alternator failing and not turning completely freely.

  6. #6
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Exactly the same symptoms on the old DTi I had last year. Just topped up the fluid. Had no warnings but it took about half a litre. Was like new aftger I topped it up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  3. Lots of warning lights + loss of power steering
    By Sparky67 in forum Vectra C / Signum Troubleshooting
    Replies: 14
    Last Post: 29th March 2012, 10:38
  4. Intermittent loss of power steering......
    By 1ctchris in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 17th May 2011, 10:20
  5. Alternator light coming on and loss of power steering
    By fairhaven in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 12th January 2009, 18:06

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •