User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 39

Thread: Cdti stuttering

  1. #1
    Regular Member
    Join Date
    Jun 2012
    Location
    Eastbourne
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Cdti stuttering

    Hi, I'm new to the forum and just bought a 2004 vectra cdti 120 in which I was told had an EGR problem. I had it diagnosed and the only fault code was p2279 which I was told was the EGR.
    It had no power due to being in limp mode etc, so last night I fitted a brand new EGR valve, cleaned up the pipe attached etc.
    After fitting it drives much better, has the power now, however, it hesitates/stutters between 1500-2000 rpm.
    Any ideas what this could be and how I could cure it?
    Any advice would be great.

  2. #2
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    If memory serves me correct (and I am not 100% sure) but I recall there is a software update for the CDTi 120 (not 150) that may be available because EGR design for the 120 may have evolved a bit. As said, I am not 100% sure.

    When I fitted a new EGR to my 150, I did get a slight hesitation at about 2 K revs (as if the turbo was overbooting and cutting for a tad or two). I simply disconnected the battery for an hour to reset all the elctronics and it has never re-appeared. Maybe worth a try.

  3. #3
    Regular Member
    Join Date
    Jun 2012
    Location
    Eastbourne
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ok thanks, il give it a go.
    Drove to work this morning and it went into limp mode whiles driving up hill then went back to normal again?

  4. #4
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i do follow a lot of threads on here
    have a look at this
    it may help
    i will also find you another which may help to

    http://www.vectra-c.com/forum/showth...-loss-of-power

  5. #5
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  6. #6
    Regular Member
    Join Date
    Jun 2012
    Location
    Eastbourne
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    That's great! Thanks!

  7. #7
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by gtirobbie View Post
    That's great! Thanks!
    by the way welcome to the site

    there are a lot of knowlegeable people on this forum

    it is very addictive

    keep us updated on how you are doing

    enjoy

    vectra ste

  8. #8
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    more info for you

    this may be useful in the future

    http://www.vectra-c.com/forum/showth...id+Malfunction

  9. #9
    Regular Member Marky's Avatar
    Join Date
    Jun 2006
    Location
    North West
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    These problems can often be cured by cleaning the EGR or replacing it. But it does seem to come back again. So people have been blanking off the EGR and getting it 'mapped out' of the cars computer. This 'mapping' usually costs between £100-200 so can be cheaper than replacing an EGR. And it doesn;t cost much more for a tuning map with power gains.

    If you disconnect the EGR and the problem goes away (you will get a light on the dashboard showing the EGR is not working) then this should point to an EGR problem.

    However there seems to be a new way of thinking in that its not just the EGR but also the vacuum/boost control solenoid that also get clogged up over time and can cause this hesitation. Cleaning the little filter or just removing it has helped a few people. The link in vectra ste's second post (#5) takes you to a thread all about this.

  10. #10
    Regular Member
    Join Date
    Jun 2012
    Location
    Eastbourne
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks for all your advice etc, where is the boost control solenoid located?

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stuttering turbo
    By Ronnie-29 in forum Troubleshooting
    Replies: 0
    Last Post: 6th February 2012, 21:30
  2. Stuttering 2.2 Elite
    By Dogsbodyone in forum Engine & Drivetrain
    Replies: 3
    Last Post: 4th November 2011, 00:54
  3. stuttering uphill
    By ALD in forum Engine & Drivetrain
    Replies: 6
    Last Post: 11th April 2011, 12:53
  4. 2003 3.0L cdti Signum stuttering.....
    By Minuteman in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 27th December 2009, 02:10
  5. 2.2 Dti stuttering under load - help
    By Boyden in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 20th December 2009, 20:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •