User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Engine vibrate, sluggish and loud

  1. #1
    Regular Member
    Join Date
    Feb 2011
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine vibrate, sluggish and loud

    My Signum 2.2 direct has had an oil leak for a long time now, i just keep topping it up as the cheapest option.

    I topped it up the other day and drove it the day after and it feels awful. It is lacking power, not a lot but noticeable. It seams to vibrate when accelerating and sounds louder than usual.

    I havent put to much oil in and every thing else seams fine.

    It feels like the brakes are stuck on but when you put the clutch in it free wheels fine.

    It idles fine.

    Any ideas?

  2. #2
    Regular Member VVT-i-MATT's Avatar
    Join Date
    Feb 2012
    Location
    Calne UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    when you say "oil leak" where from exactly?

  3. #3
    On a Sabbatical
    Join Date
    May 2012
    Location
    chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does it rattle for 2 to 3 seconds when you start it up cold. Top end rattle then go quiet?
    Last edited by GT3071R; 15th June 2012 at 23:58.

  4. #4
    Regular Member
    Join Date
    Feb 2011
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the oil is leaking near the belt and it flicks it everywhere so hard to say really. It only leaks when engine is running. No it does not rattle when starting up. I think it will be too hard to explain on here. think I will have to take it somewhere.

    I have ordered a new astra J vx line which comes in 3 weeks so was going to sell the signum anyway. Probably have to sell as spares or repair now.

  5. #5
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    I have a slight leak from the crank oil seal and its similar to how yours sounds, needs a service soon so getting it all done at the same time...

  6. #6
    On a Sabbatical
    Join Date
    May 2012
    Location
    chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Crank oil seal. What's new there then Lol. Best to take it in mate like you said

  7. #7
    Regular Member
    Join Date
    Feb 2011
    Location
    Mansfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    would this cause the problems that I am having or is this something else do you think.

  8. #8
    Regular Member Lozza's Avatar
    Join Date
    Jun 2011
    Location
    Brum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c

    Trim : SRI

    Engine : 1.8

    Year : 06

    Default

    sorry to jump on your thread... i have a slight oil leak on my Z18XE... can the seal make a tinny rattling noise underload as when im driving, at high revs
    around 3000 rpm i can hear a tinny/matlic rattle. I ve had a new exhaust and the noise is still there, all the heatshields are sucure.

  9. #9
    Regular Member TonyP2020's Avatar
    Join Date
    Dec 2009
    Location
    Wirral, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Mokka

    Trim : SE - Orange Rock 's !!

    Engine : 1.7CDTi

    Year : 2014

    Default

    I would say start with the easy things, spark plugs, airfilter, belts loose/slipping, etc.,


    Quote Originally Posted by JonJoe View Post
    My Signum 2.2 direct has had an oil leak for a long time now, i just keep topping it up as the cheapest option.

    I topped it up the other day and drove it the day after and it feels awful. It is lacking power, not a lot but noticeable. It seams to vibrate when accelerating and sounds louder than usual.

    I havent put to much oil in and every thing else seams fine.

    It feels like the brakes are stuck on but when you put the clutch in it free wheels fine.

    It idles fine.

    Any ideas?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra c 1.9cdti xp2 very loud and ticking engine noise
    By atty in forum Engine & Drivetrain
    Replies: 0
    Last Post: 26th August 2012, 14:07
  2. vectra c 2.0 dti sluggish engine
    By Legion84 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 19th July 2012, 17:37
  3. Cdti lack of power engine sluggish
    By Diesel Dude in forum Engine & Drivetrain
    Replies: 6
    Last Post: 19th January 2011, 16:07
  4. Engine more sluggish, mpg dropping :(
    By markluk in forum Engine & Drivetrain
    Replies: 5
    Last Post: 19th January 2009, 08:52
  5. very loud 1.9 cdti engine
    By ziggi in forum Diesel Engine related
    Replies: 9
    Last Post: 24th December 2007, 01:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •