User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Engine Management Light On After EGR Blanking.

  1. #1
    Regular Member trucklord's Avatar
    Join Date
    Jun 2012
    Location
    Retford , Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Talking Engine Management Light On After EGR Blanking.

    Greetings
    Well its been a week since I got the Vectra 1.9 CDTi 150 ( 2004 )
    And after not touching a car engine for 15 years at least ive had the spanners out and had a tinker about :-)

    today was the turn of the EGR clean out ( not too bad really - and solenoid worked )

    20120608_161553-_800.jpg
    20120608_162035-_800.jpg20120608_163646-_800.jpg

    Then fit a blanking plate to EGR and put back together.
    Also the Boost Sensor was completely caked up with gunk ! - how that even worked is beyond me.
    Nice and clean now :-)

    20120608_170517-_800.jpg

    Anyway I had previously cleared all the fault codes and now I get the orange engine picture light ( bottom right of dashboard picture ) on all the time.

    I took the car for a spin and it drove fantastically - no more intermittent judder about 1700 revs - ( swirl flaps still spinning on their own - that jobs next, superglueing the washers on now ) - The turbo kicks in earlier and the wheels spin much better in 2nd and third thanks :-)

    20120608_171121-_800.jpg

    Apart from the warning light on its all good - Is this cos the EGR valve is blanked ?
    Hope someone puts my mind at rest., thanks.

  2. #2
    Regular Member Mark-R's Avatar
    Join Date
    Mar 2012
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : GSI

    Trim : (vxr/irmy)

    Engine : 3.2 v6

    Year : 2004

    Default

    Yeah the EML comes on if you completely blank it but if u put a small hole in the blanking plate it stops the light from coming on

  3. #3
    Regular Member trucklord's Avatar
    Join Date
    Jun 2012
    Location
    Retford , Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks. I've just reset fault codes again and the EML has gone off - just leaves the spanner light in the middle now.
    Fault codes are now..
    20120608_193419-_800.jpg

  4. #4
    Regular Member Mark-R's Avatar
    Join Date
    Mar 2012
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : GSI

    Trim : (vxr/irmy)

    Engine : 3.2 v6

    Year : 2004

    Default

    Yeah mine did the same but after a whil the spanner light went off and the EML light came back on but not ive drilled it doesn't come on.

  5. #5
    Regular Member trucklord's Avatar
    Join Date
    Jun 2012
    Location
    Retford , Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'll just leave it then - swirl bar tomorrow.
    Oh the joys.
    Thanks Mark

  6. #6
    Regular Member Mark-R's Avatar
    Join Date
    Mar 2012
    Location
    Dundee
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : GSI

    Trim : (vxr/irmy)

    Engine : 3.2 v6

    Year : 2004

    Default

    Np i need to wait for my car to come back from rockness before i can do anything to it lol

  7. #7
    Regular Member
    Join Date
    Jun 2009
    Location
    Cheltenham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Mine comes on even with the hole

    On my 120 I tried no hole, 5mm 10mm and 12 mm holes and although the light goes off most of the time it still comes on just to annoy me. it's fine on the motorway but seems to come on on the slow stuff, the bigger the hole the longer it stays off.

  8. #8
    Regular Member trucklord's Avatar
    Join Date
    Jun 2012
    Location
    Retford , Notts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The first pic I posted here is looking into the inlet manifold - all caked up with soot.
    Don't want all that Shi*e going through the engine.
    Will put up with a warning light as long as I know what it is for.
    What bothers me more is the power steering issue - intermittently not working, then get out wiggle the connection on the pump and it works again.
    Except the connections are secure.

    Why can't cars be simple like they used to be.

  9. #9
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by trucklord View Post
    The first pic I posted here is looking into the inlet manifold - all caked up with soot.
    Why can't cars be simple like they used to be.
    Oh yes, why indeed!! Give me a window winder any day. A set of points to play with and a cable operated choke knob.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

vectra c egr blanking engine management light

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •