User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Instrument panel

  1. #1
    New Member
    Join Date
    Jun 2012
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Instrument panel

    I have an 05 vectra. The instument panel has developed a fault. All will be working, then the red warning lights will come on followed by the steering wheel warning light and then all of the instruments will stop working including odometer. Sometimes they will come on after a restart, sometimes not. Any ideas on how to correct?

  2. #2
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    http://www.vectra-c.com/forum/showth...=1#post1414186

    Check this out first as its easy and cheap if not this may need a diagnostic check

  3. #3
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    60 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    You can also check/replace fuse 17 in the fusebox on the passenger side of the dashboard. Had this happen on mine and it was the fuse had gone high resistance, changed the fuse and it's never done it since.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  4. #4
    VIP-Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Turdsville
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    37 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Lada

    Trim : Riva

    Engine : 6.0 V12

    Year : 1954

    Mileage : 567890987

    Default

    , abs plug will be the most likely cause.

  5. #5
    Regular Member
    Join Date
    May 2012
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yeah I have this exact fault on my '06 1.8 vvt - driving along, red warning lights followed by lots of lights followed by the cluster dying. Restart fixes it. I'll try the fixes mentioned here and report back!

    copperkettle, did you have any luck?!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VXR instrument panel?
    By the_rocker in forum Styling
    Replies: 11
    Last Post: 17th April 2012, 12:19
  2. Instrument Panel Indications
    By jimbojetset in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 4th July 2011, 19:09
  3. My instrument panel cluster is not working
    By bale541 in forum Electrical & ICE (including SatNav)
    Replies: 20
    Last Post: 20th May 2011, 11:38
  4. Instrument Panel Lighting
    By dc6839 in forum Bodywork & Interior
    Replies: 1
    Last Post: 29th July 2010, 12:17
  5. Insignia Instrument Panel.
    By Maverick in forum Insignia car chat
    Replies: 15
    Last Post: 7th June 2008, 13:19

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •