User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Thermostat and other problems maybe? Advice please!

  1. #1
    New Member
    Join Date
    Jun 2012
    Location
    Leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Thermostat and other problems maybe? Advice please!

    Hi all,

    I have a 2004 vectra 2.0 DTI. Had a number of problems in the past, but this latest string of problems started at the start of this year.

    Started off when EML came on and stayed on whist ever car was running, took it to a garage who said it was a mass air-flow system problem and they replaced the part. I also told them i thought a turbo pipe was split as could hear the air rushing noise, but was unable to locate myself. So anyway, they fitted the new mass air flow and they patched up the pipe as they said it was cheaper, but EML kept coming back on whenever using the car.

    Changed the turbo pipe myself in the hope that was the only problem and took the car for a spin. EML was still on at this point. As soon as car got above around 60degrees, car went into safe mode / limp home mode whenever turbo was used, as it was doing before with the pipe split.

    Took car back to garage who said they wern't sure what it was and could no longer read the fault, but the mass air flow they fitted was still all good. Sounded like a bit of a cop out to me, but hey, oh well.

    So then came the other day when driving with a macdonalds in the car to eat at home. Decided to put heaters on to keep food warmer, as car was running at around 80degrees and not yet in safe mode as only just re-started engine. Heaters wouldn't blow any warm air out, gave them about 5mins to see, but still only cold coming through, which leads me to believe that car now has a thermostat problem. I am in the process of getting one delivered, but wondered if anyone had any ideas on what the other problem could be? And could this also be related to the thermostat too???

    i have spoken to a couple of mechanics i know about this, and also checked various forums online and seem to get a number of different things it could be. Any ideas greatly appreciated.

    Thanks in advance all, sorry for the long post

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check that the heat flap control is actually moving.

    Was maf a genuine one?

  3. #3
    New Member
    Join Date
    Jun 2012
    Location
    Leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Critch View Post
    Check that the heat flap control is actually moving.

    Was maf a genuine one?

    I will check it in morning actually, something i never thought to check.

    And yeah, maf was genuine, or so the garage told me, took them around 2 days to get one in as well.

    Thanks again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.8 vvt (Z18XER) Thermostat Problems
    By sambuka in forum Engine & Drivetrain
    Replies: 22
    Last Post: 11th January 2013, 21:27
  2. vec c 1.8 thermostat problems, symptoms?
    By taffy bhoy in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 15th December 2012, 10:41
  3. Replaced Thermostat - some advice please.
    By colreid in forum Engine & Drivetrain
    Replies: 13
    Last Post: 22nd April 2012, 19:18
  4. Help!!!! Thermostat advice
    By Cilldara1 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 13th January 2011, 20:05
  5. Thermostat advice needed Z18XE
    By Saulty in forum Engine & Drivetrain
    Replies: 26
    Last Post: 17th November 2010, 22:28

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •