User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: weird noise in engine bay. 1.9cdti 120ps 2005

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    St ives
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default weird noise in engine bay. 1.9cdti 120ps 2005

    Ok so apart from the struggling to start problems which i am looking into:-

    Glow plugs, Leak off pipes, Injector seals, battery, starter motor.

    I can here a loud noise coming from the drivers side of the engine bay, sounds as if its underneath where the air box is, sounds almost like a metal scraping on metal sound.

    Can anyone please recommend what this may be and how i go about fixing it.

    Many thanks
    Alex

  2. #2
    Regular Member barney490's Avatar
    Join Date
    Dec 2009
    Location
    PRESTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check the crank pulley. These are a vibration damper with a rubber core, they split and the outer ring seperates from the inner.

  3. #3
    New Member
    Join Date
    Jun 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine used to struggle get your battery checked first before you do anything else, and as above it will be a pulley that's making the noise shouldn't be to costly if replaced sooner rather than later

  4. #4
    Regular Member wildchild's Avatar
    Join Date
    Sep 2011
    Location
    west-mids
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : elite

    Engine : 1.9 cdti 16v 150

    Year : 06

    Mileage : 111250

    Default

    hi m8 theres a thread on here about the difficult to start bit n the op sorted it with a new starter motor its in engine and drivetrain section hth
    gaz

  5. #5
    Regular Member
    Join Date
    May 2012
    Location
    St ives
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the replies. I've been looking through the service book and I don't think the belt has ever been changed. 7 years/108,000 miles. Are the belt kits with pulleys on eBay any good?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird Engine Noise after Service 2.2 Petrol '04
    By solamanda in forum Engine & Drivetrain
    Replies: 3
    Last Post: 22nd August 2012, 20:04
  2. weird noise 1.9cdti
    By tomo610 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 19th February 2012, 17:07
  3. Weird engine problem on a 1.9cdti 150!!
    By new2theroad in forum Engine & Drivetrain
    Replies: 0
    Last Post: 2nd July 2011, 23:48
  4. Irritating Whirring Noise... grrr 1.9cdti (120ps)
    By Meady in forum Engine & Drivetrain
    Replies: 2
    Last Post: 6th April 2011, 07:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •