User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: signum z20net engine.

  1. #1
    Regular Member
    Join Date
    Jan 2012
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default signum z20net engine.

    hello there can anyone tell me if i can get my ecu tested only just had car in vauxhall garage on test for missing and it came back found multiple trouble codes stored in vehicle possible ecu;or air flow metre or head removing phoned a london firm been going since 1972. and they said its the one ecu they cant test does anyone know different please come out to play all you experts thanks ray.

  2. #2
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum & Insignia

    Trim : Elite

    Engine : POS derv

    Year : 2014

    Default

    The ECU is a Trionic 8, made by motorola i think. Its unique to the saab engines (which you have). Its pretty much a bullet proof ECU to be honest so is the engine and your dealership woill not know what to do with it, all they do is swap parts when you do not need to.

    What are you symptoms?

    What were the fault codes?

  3. #3
    Regular Member
    Join Date
    Jan 2012
    Location
    essex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the first time i took it it came back with code 300 this time with the things i said no codes were given my problen has been not ticking over and when it did engine shakes and theres a missing while driving but it still goes like a train on the motorway

  4. #4
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maybe it's caused by an intermittently failing ignition coil.

  5. #5
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum & Insignia

    Trim : Elite

    Engine : POS derv

    Year : 2014

    Default

    As mentioned above, coils can gi and cause symptoms like that. There is a bloke on ebay selling a set of 4 for £60 at the moment. Grab them before somebody else does as they normally cost a lot mofe than that.

    Do the pedal test and note down the stored codes then post them here.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. signum z20net engine.my exhaust.
    By rayeg1935 in forum Bodywork & Interior
    Replies: 1
    Last Post: 22nd March 2012, 10:31
  2. signum z20net engine.
    By rayeg1935 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 16th March 2012, 18:44
  3. signum z20net engine.
    By rayeg1935 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 9th March 2012, 09:34
  4. Z20NET engine oil
    By ROCKATANSKY in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 5th May 2010, 10:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •