User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: high revs no power

  1. #1
    New Member veccyDaz's Avatar
    Join Date
    May 2012
    Location
    rochdale
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default high revs no power

    ok so was on motorway up through 1st and 2nd no issues, 3rd and 4th when you change gear and accelerate the revs shoot up and thats it. speed up slightly. 5th its fine again, tried again before switching up at lower revs and down at higher revs and was fine. clutch pedal is fine no difference in resistance or biting point just seems to have a major lag, but the accelerator pedal is fine as the revs increase.

    any ideas? no leaks everything is dry and no warning lights on dash. car is a 2.0dti 04 plate with 87k miles.

    did try searching but couldnt find it answered on forum

    thanks in advance

  2. #2
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    58 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    I might be wrong, but it sounds to me like the clutch is slipping fella regardless of what the pedals doing, 3rd and 4th are where the most torque is so are the most likely gears for it to slip in and as you say it happens whilst accelerating so it's under load. See if anyone else has any bright ideas first, but if it was me I'd be getting the clutch checked.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  3. #3
    New Member veccyDaz's Avatar
    Join Date
    May 2012
    Location
    rochdale
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    getting it checked next week hoping its not that but its looking that way atm

  4. #4
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    23 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    If it is then consider that the DMF might as well be changed unless you have a new one saves doing it when it does go

  5. #5
    New Member veccyDaz's Avatar
    Join Date
    May 2012
    Location
    rochdale
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    been on to the traders where i bought it from today as statutory rights say they should pay for it as not sold fit for purpose. gotta call the tomorrow to check that they will pay for it, failing that trading standards. anyone else had to go down this route to get issues sorted? car only bought 5 days ago and 157 miles added to the clock

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. high revs
    By andy_richmond in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th October 2012, 18:43
  2. Vectra Sri 1.9 150 No power until high revs
    By rollercoaster63 in forum Engine & Drivetrain
    Replies: 11
    Last Post: 12th May 2012, 17:35
  3. Loss of power - high revs
    By ac14 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 19th March 2012, 22:11
  4. No power between 3k-4k and high revs
    By troodon in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 26th September 2009, 18:53
  5. Can you Help ~ Loss of Power, High Revs
    By Diet1985 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 28th June 2009, 18:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •