User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: A few small problems....

  1. #1
    New Member
    Join Date
    May 2012
    Location
    South wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default A few small problems....

    Hey guys it's my first time owning a vectra c and am in need of some help and advice, i bought the car just over two weeks ago it's a 2.0 dti ls model which is in fairly good condition despite the age.
    Came with bald tyres mainly worn on the outside rather than the centre or all over which slightly worried me, and the brakes needed sorting the day or two after i bought it.
    Turns out one of the callipers was leaking due to the inner piston not activating when prompted. Great.

    Anyways i've found that the driver's side front spring needs replacing because it's cracked and slipped at the bottom but has come around to tear my tyre to shreds.
    Now looking at the top of the strut it looks like i need some female torn sockets to get the strut out, is that right?

    besides that i've replaced both track rod ends because they were absolutely knackered, makes me think if this caused the tyres to wear on the outside. but then took it to get my tracking sorted only to find that the passenger front side needs a new ball joint because it's wiggling like a loose tooth. Does anyone know if i need to replace the entire wishbone/suspension arm or is there a part that i can straight up replace?

    I've also noticed some knocking coming from the rear end driver's side every time i go over a few bumps which makes me think it's the suspension bush, but i've jacked the car up and given the alloy a good pull at 9 and 3 to make sure and there's no give at all. anyone have any idea what the knocking might be?

    any help is appreciated guys, thanks

  2. #2
    Regular Member SarahP's Avatar
    Join Date
    Nov 2011
    Location
    Buckinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    we had a knock/bump when we went over a high speed hump or round a sharp bend, turned out (after having an advisory from MOT for it last year) it was our rear upper suspension arm bush had slight play in it, changed it and not had it since (touch wood!)

  3. #3
    New Member
    Join Date
    May 2012
    Location
    South wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by SarahP View Post
    we had a knock/bump when we went over a high speed hump or round a sharp bend, turned out (after having an advisory from MOT for it last year) it was our rear upper suspension arm bush had slight play in it, changed it and not had it since (touch wood!)
    sounds like a pretty common fault with vectras, was it expensive can you remember? because i'd rather do it myself and save the pounds.

  4. #4
    Full Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    To check leave car on ground hold wheel at 12 and push and pull.

    http://www.vectra-c.com/forum/showth...s-if-needed%29

  5. #5
    VIP-Member Damo77's Avatar
    Join Date
    May 2010
    Location
    Petersfield, Hampshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by troutybrown View Post
    To check leave car on ground hold wheel at 12 and push and pull.

    http://www.vectra-c.com/forum/showth...s-if-needed%29
    Quick video description here as well

    http://www.youtube.com/watch?v=h-LF-...ure=plpp_video
    Already replaced:-
    Alternator,
    Drilled/Grooved Discs & Pads, Eibach Springs, EGR Valve, 50W HID's 6000k, K&N Panel Filter, LED footwell & boot lights

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. z18xer vvti, problems, problems
    By gstore in forum Engine & Drivetrain
    Replies: 15
    Last Post: 20th April 2012, 13:33
  2. 1.8 vvti problems, problems problems!!!
    By gstore in forum Petrol Engine related
    Replies: 8
    Last Post: 3rd March 2012, 01:31
  3. crusie control problems, anyone had similar problems?
    By rozzer2006 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 2nd October 2011, 21:20
  4. 1.9 cdti auto problems problems
    By trigger in forum Engine & Drivetrain
    Replies: 2
    Last Post: 28th September 2009, 17:20
  5. small mod done
    By david-bell in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 29th January 2006, 11:22

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •