User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: P0638 and EGR problems

  1. #1
    Regular Member
    Join Date
    Dec 2011
    Location
    Norway
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default P0638 and EGR problems

    Hi all,

    My '04 2,0 DTI keeps going into limp mode and spanner light comes on. Turn engine off and back on right away and everything is fine. Fault code P0400, and I've cleaned the EGR several times. Usually it drives fine for some time after the cleaning, but will eventually fall back into it's old habits...

    The other day I got a spanner light that just stayed on for a few seconds then disappeared. No limp mode or nothing. Garage said fault code P0638. A few weeks later I cleaned the EGR again but after only 2 hours of driving the limp mode and spanner light returned. Does that mean that the EGR is beyond where cleaning will help and needs to be replaced, and can this be related to the P0638 code at all? Or are those to separate problems?? Any help appreciated.
    Daniel

  2. #2
    Full Member bobssignum's Avatar
    Join Date
    Dec 2007
    Location
    polishing something or other somewhere
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    The p0638 fault code in its various forms is usually related to the throttle position sensor or its related diagfram or butterfly valve or if fitted the vacuum hoses attached to them .
    Now exactly what the problem could be on these depends on what type of upper manifold you have fitted
    Do you have an upper manifold with the TPS fitted there or is your tps on the throttle pedal itself
    If you have the tps on the manifold then i would suspect that the manifold is itself gunged up and needs a clean , make sure the butterfly valve inside the manifold can move freely also clean the boost sensor as well .
    Dont remove the tps sensor from the manifold leave in position , The next stage is to check your vacuum hoses for signs of perishing/cracking , a very common problem on these DTi,s .#
    What we usually do is to replace them with silicone tubing 3 metres of 3mm tubing is enough to do all the vacuum hoses around the engine bay
    I dont know about euro prices but around £7-8 for 3 metres is the normal price here in the uk

    hope this helps If you need any more info give us a shout
    regards bob
    Driving vauxhall,s for 30 + years
    and still loving it

  3. #3
    Regular Member
    Join Date
    Dec 2011
    Location
    Norway
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    TPS is on top of manifold. About 2 months ago I cleaned the manifold using the great How2 from this site. After that the EGR was fine until recently when it startet acting up again. I will clean the boost sensor and check for leaks in the vacuum hoses - and probably replace them anyway. I'll get them through Ebay. Thanks for the info, will keep posting my results. I've searched through this forum quite a bit, and realize I'm not the only one with this or similar problems....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fault code P0638
    By eileeng2 in forum Electrical & ICE (including SatNav)
    Replies: 12
    Last Post: 4th July 2012, 14:40
  2. P0638
    By tomo610 in forum Troubleshooting
    Replies: 3
    Last Post: 1st July 2012, 19:29
  3. Fault Code P0638
    By Micknal in forum Engine & Drivetrain
    Replies: 0
    Last Post: 10th November 2011, 15:22
  4. Fault code P0638
    By Micknal in forum Engine & Drivetrain
    Replies: 0
    Last Post: 9th November 2011, 17:43
  5. Fault code P0638
    By Micknal in forum Engine & Drivetrain
    Replies: 0
    Last Post: 9th November 2011, 17:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •