User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: My Vectra 150 cdti engine plays the drums ? :S

  1. #1
    New Member Jimmy89's Avatar
    Join Date
    May 2012
    Location
    tamworth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default My Vectra 150 cdti engine plays the drums ? :S

    Soo, I was on my way home from a long trip, car was doing GREAT, up until I was about 25 miles away from home, the car just started shaking and then the car and spanner light came on, I went into limp mode Q_Q couldn't go over 50 ALL the way home, which sucked big time .

    I EVENTUALLY got home, let it cool down, and tried again, the engine sounds like its playing the drums, and generally pretty rough, the engine management light is on, and the drums stop playing as soon as I start moving or depress the clutch but I am still in limp mode and my engine does not sound good.

    Just wondering if anybody has any ideas to fix the problem, I have a code reader on the way, should be here Monday, but fingers crossed on it not being my flywheel, I REALLY don't want to pay for one of those, so any other suggestions would be GREATLY appreciated.

  2. #2
    New Member Jimmy89's Avatar
    Join Date
    May 2012
    Location
    tamworth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Additional info, I drive the car like a GRANNY most of the time trying to keep my mpg up as I am poor :*( also the car was serviced about 400 miles beforehand if that might add to the equation. and since it has happened i have cleaned my EGR valve in high hopes, but it had no effect also, the car has been mine for about 9 months, and iv put 12k ish miles on it.

  3. #3
    Regular Member DTi Elite's Avatar
    Join Date
    May 2012
    Location
    county durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Elite

    Engine : 1.9 cdti 150

    Year : 2007

    Mileage : 145k

    Default

    from what you are describing it does sound flywheel related , flywheel can cause an engine management light to come on if it makes the engine run really rough & the ECU cannot correct the rough running .

  4. #4
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    Could be 3rd injector connector if its yellow you can get a blue kit from Vauxhall


    http://www.vectra-c.com/forum/showth...njector-wiring

  5. #5
    New Member Jimmy89's Avatar
    Join Date
    May 2012
    Location
    tamworth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Soo, had it code read today, and its my 4Th injector circuit, so close troutybrown :P Which I am so happy about, since i don't need a new flywheel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine rattle vectra 150 cdti.
    By sla002 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 4th August 2011, 17:40
  2. Vectra 1.9 CDTi (150) - engine rattle
    By srcrossley in forum Engine & Drivetrain
    Replies: 12
    Last Post: 20th October 2007, 09:29
  3. Vectra 3.0 CDTI Engine
    By mystical in forum Vectra C / Signum Car Chat
    Replies: 32
    Last Post: 17th March 2007, 18:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •