User Tag List

Thanks Thanks:  1
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Heater Blower Issue - Only works on Position 4

  1. #1
    Regular Member
    Join Date
    Apr 2010
    Location
    Doncaster
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry Heater Blower Issue - Only works on Position 4

    Hi guys,

    Am hoping someone can help save me from tearing my hair out!

    As the title would suggest, the internal heater blower only works on #4. No action on 1-3.

    When moving the fan control from 0-1, I can hear the relay clicking. AC and heat control are both fine.

    For the record, I've replaced the heator resistor and heater switch relay.

    I've also checked the fuses.

    Am completely out of ideas now. What about everyone else?

    Don't want to pay stealer prices to be diagnosed then fixed

    Cheers

  2. #2
    Regular Member krazylegz's Avatar
    Join Date
    Dec 2009
    Location
    South Shields
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Was it a new resistor you replaced it with?

    Could well be the control panel itself

    Sent from my iPhone using my fingers n thumbs

  3. #3
    Regular Member
    Join Date
    Apr 2010
    Location
    Doncaster
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    brand new resistor and relay - yep

    Any other ideas than the control panel? If no, where could I get one for low cost?

  4. #4
    Regular Member
    Join Date
    May 2010
    Location
    Newbury
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I have exactly the same symptoms too. I can hear a click near the glove box when changing fan setting from 0 to 1 and that the blower only works on setting 4. Was there any outcome for fixing this fault?

  5. #5
    Regular Member Hideous's Avatar
    Join Date
    Mar 2007
    Location
    GB
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    same problem with mine - only works on position 4, recently.
    yet another common vectra fault by the sound of it - only bothering to fix if it's a diy job.

  6. #6
    Regular Member
    Join Date
    Jan 2011
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Same problem here too.

  7. #7
    New Member
    Join Date
    Jun 2012
    Location
    norfolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i also have this problem, just wondering if you got is sorted?

  8. #8
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  9. #9
    Regular Member wardy23's Avatar
    Join Date
    Nov 2011
    Location
    North Yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    got to be the heater resistor pack thats the only thing that makes 1-3 work

  10. #10
    Regular Member
    Join Date
    Apr 2010
    Location
    Doncaster
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile

    After much frustration (and a word with an ex-masterfit manager), I bought a second new heater motor resistor.

    After fitting, hey presto... it starts working on 1, 2 and 3 again.

    Needless to say, I've taken the first "new" resistor back to Euro Car Parts and got a full refund.

    To confirm, if you've got a full fan on 4 but not 1-3, try a new heater resistor first. If the replacement resistor doesn't work, buy a second to confirm the replacement isn't faulty. That worked for me

  11. Thanks JDM thanked for this post
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Weird problem with heater blower only works with the lights off
    By evhop in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 4th November 2012, 22:02
  2. Heater Blower Issue - Only works on Position 4
    By phughes64 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 5th June 2012, 20:47
  3. Heater/Blower Issue... Relay problem with PICS!
    By lew1984 in forum Troubleshooting
    Replies: 8
    Last Post: 13th August 2011, 18:24
  4. heater blower only works on 4 speed
    By hippo in forum Heating, Ventilation & Air Conditioning (HVAC)
    Replies: 2
    Last Post: 9th February 2010, 14:38
  5. Heater blower only works in highest setting
    By David Schofield in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 23rd November 2009, 19:59

Visitors found this page by searching for:

vauxhall vectra heater only works on 4

vectra 2 2 heater works on 4 speed only

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •