User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Really fed up with hid direct

  1. #1
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    So when I got my car the 1st thing I got was hids from hid direct last July. couple of months later both went out, stopped working not at same time .the ballests where coverd in white like corrotion. so sent them back new ballests within couple of days so I thought id silicone the ballest to seal them but guess what.... the passenger side has gone out. So took it out and it's coverd in white stuff argh!!!!!!!! I've now had to put my spare one which I've had years and working strong and well , anyone else had this problem or whats doing it
    Last edited by marc vectra sri; 14th May 2012 at 21:05.

  2. #2
    Regular Member Barlow's Avatar
    Join Date
    Jan 2012
    Location
    Chester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan 350Z GT


    Engine : 3.5 V6

    Year : 06

    Mileage : 50,000

    Default

    They ripped me off on ebay when the kit they sent had a dud ballast and they went quiet. Cut a long story short I bought a ballast and everything worked great. Then the other HID Direct ballast gave up just a couple of weeks ago, so had to buy another ballast. Oh, and a bulb went about 2 months ago.
    Their gear is crap and they're crap.

  3. #3
    Full Member Leemarksmith's Avatar
    Join Date
    Jun 2008
    Location
    Hanging Heaton / Batley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi (VXR Styling)

    Engine : Z19DTH (Re-mapped)

    Year : 04

    Mileage : 110k

    Default

    I've only just got a bulb warning issue now (lights every time like), happens 50% of the time but goes out after 5 mins of driving. been on 2 years...

    Seems to be luck of the draw. if i replace anything i'll just buy a cheap kit elsewhere and only cancelers from them.

  4. #4
    Regular Member Angel1368's Avatar
    Join Date
    Mar 2012
    Location
    liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : VXR

    Engine : 2.8 V6 turbo

    Year : 2006

    Mileage : 44,000

    Default

    im meant to be calling there tomorrow lol

  5. #5
    Full Member Niall83's Avatar
    Join Date
    Nov 2009
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've never had a problem with them. Got my kit off them 2 years ago, only changed a bulb about 2months ago, so I'm happy with it all.
    AirBox Mod-Angel Eye head lights-HID 5000k-Colour coded grill-GID to CID-Auto Dim rear view Mirror, Rear Parking Sensors, Signum Fog surrounds, 19" Audi A5 rep Alloys, Eibach 30mm Pro-kit Lowering Springs.

  6. #6
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    Quote Originally Posted by Angel1368
    im meant to be calling there tomorrow lol
    I'd get a kit on eBay cheap one then buy cancerlers I've had my cheap kit for 5 years in my vec now

  7. #7
    Regular Member
    Join Date
    Apr 2011
    Location
    Las Vegas
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had mine two weeks and one of the ballasts failed,they told me i had to take it off the car and wait for a new one, took about three weeks to sort out but all was well in the end. Been on the car for 10 months now.... touch wood

  8. #8
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    Reviews seem ****e about them if they don't take these back going have to buy new set

  9. #9
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    44 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Had mine4 years in the Vectra and siggy no orbs at all still on the same bulbs aswell
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  10. #10
    Regular Member chewy71's Avatar
    Join Date
    Sep 2010
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I think it's all down to where they are sited. I bought mine from HIDS4US originally, and I suffered the same, white type corrosion on them.
    They were originally sited within the wing of the car. I then bought replacements from CarmodShop and also Hids Direct, and now they are mounted on the crash bar legs - where it is dry and very draughty. If you read the instructions, it clearly states they are to be sited in a draughty location. I would suspect the siting of your ballasts is the reason.
    Been in well over a year now with no issues.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I think my 2.2 direct has too much oil in it....
    By Knuckle in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 1st June 2011, 15:18
  2. vectra 2.2 direct/non direct
    By denzilbud in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 9th July 2009, 00:05
  3. 2.2 Direct mpg normally this bad?
    By Marc C in forum Engine & Drivetrain
    Replies: 18
    Last Post: 9th August 2008, 12:46
  4. 2.2 Direct 16v
    By cdms811 in forum Petrol Engine related
    Replies: 14
    Last Post: 12th December 2007, 00:55
  5. 2.2 Direct
    By VauxVeteran in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 15th November 2007, 20:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •