User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: 1.9 CDTi Swirl Valve Issue

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 1.9 CDTi Swirl Valve Issue

    Hi all,

    New to the site, apologies for first post being a problem!

    Picked up a 54 plate 1.9 CDTi 150 Vectra over the weekend. Had the engine cover off today and noticed a possible issue with the swirl valve actuator rod.

    It's connected to all of the valves, but there seems to be a lot of play in it. ie you can hook a bit of wire under it and pull the top of the black valves up towards you a couple of mm (which is what the Pierburg bulletin warns of) and you can pivot the bar backwards (towards back of engine bay) but it flops back as soon as you let go. There is also a bit of oil sitting on top of each valve.

    The car isn't smoking there is no light and it drives fine but today it lost power twice quite markedly pulling away from a roundabout and wouldn't rev until I dipped the clutch and very slowly the revs picked up to about 3k and then were fine again. This could quite easily be something else of course, but would that be indicative of a sticking/failing valve?


    Does this sound like impending inlet manifold replacement? or am I looking for faults

    Thanks for any info
    Last edited by Ninj; 13th May 2012 at 20:02. Reason: clarity

  2. #2
    Regular Member
    Join Date
    May 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Forum back up - bit more digging reveals something very similar here

    Sounds like could be a matter of time and with the amount of miles I'm doing - will probably be sooner rather than later

    With regard to the problem I had today, is it likely that is something different? Would the swirl valve fault just clear after a few seconds of poor running and be fine for the rest of the journey? Judging by the state of the boost sensor, there's not been a regular de-coking regime going on!

    What are the best steps to safeguard against failure? I'm assuming give the EGR/inlet manifold a good clean out to make sure the swirls aren't having to work against all the crud, is it worth blanking the EGR and putting up with the EML?

    I'm thinking perhaps the warranty I'm just taking out is a good step.
    Last edited by Ninj; 13th May 2012 at 22:09.

  3. #3
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ok, start with the easy things first and most probable. First thing I would suggest is the EGR valve. If you have access to a code clearer then you can disconnect the EGR valve electrical connection and drive it around for a couple of weeks (you will need to clear the code when you eventually re-connect it or drive around a couple of weeks until the spanner before startup dissappears). There is a very high percentage probability that if it is the EGR valve causing the problem, then the car will drive fine without further issue while it is disconnected (you will also get the eml light on the dash but this will go out when you re-connect EGR). If this is so, then it is the EGR is your problem. You can either clean it or buy a new one (£100 approx). Next I would take out and clean the MAP sensor (easily done, costs nothing but carb cleaner).

    Now to the swirl valves. Yes, they can cause limp mode if they are sticking. However, I would look at the above firstly. When my swirl valve rod fell off, I glued valves 1,2 and 4 copiously. There are plenty of posts on this forum about gluing them open, do a search.

  4. #4
    Regular Member
    Join Date
    May 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks mate, I was thinking along the right lines then I think. Whipped out the MAP sensor and cleaned it. No re appearance of the limp mode (I assume that's what I had when the car wouldn't rev?) but only a 15 min journey each way this morning.

    EGR is next, hadn't thought about disconnecting it and driving it for a bit - top idea thanks. Beyond that I fancy giving it all a proper clean so the valves aren't being worsened.

    Also hadn't realised you could glue the valves open. I'm guessing that will also put up a fault code or does it just = smokey running. I'll have a search for it.

    Thanks again

  5. #5
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Also check that injector plug number 3 is blue and not yellow, if its yellow it needs replacing with an upgraded blue plug and wire sooner rather than later.
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  6. #6
    Regular Member
    Join Date
    May 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Ta very much - I'll check it right now

  7. #7
    Regular Member
    Join Date
    May 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    She be Yellow.......

    Meant to say got a op-com on the way, I reckon it might get some use
    Last edited by Ninj; 14th May 2012 at 13:18.

  8. #8
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  9. #9
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Ninj View Post
    She be Yellow.......

    Meant to say got a op-com on the way, I reckon it might get some use
    i am sure you meant a software diagnostic tool..........................
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  10. #10
    Regular Member
    Join Date
    May 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yep, got it thanks.


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Quick help please - cdti swirl/light/water damage issue
    By sandbagsniper in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 9th July 2012, 21:02
  2. CDTI Swirl Valve
    By leeds vectra in forum Vectra C / Signum Car Chat
    Replies: 43
    Last Post: 25th March 2011, 18:12
  3. are 2007 CDTI SRI 150s prone to Swirl Pot issue
    By circushead in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 30th November 2010, 18:24
  4. 1.9 CDTi 120. EGR, Swirl Valve or ???
    By mjsignum in forum Engine & Drivetrain
    Replies: 24
    Last Post: 13th April 2010, 15:23
  5. 1.9 CDTi Swirl valve
    By djr69uk in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 27th August 2008, 16:14

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •