User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: The curse of the 1.9 cdti Sri 150 strikes again

  1. #1
    New Member
    Join Date
    Apr 2012
    Location
    Cambridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default The curse of the 1.9 cdti Sri 150 strikes again

    Having a problem with my vectra 05 cdti Sri 150
    A few weeks ago I pulled away from junction and had power for a second and now have no power.

    I have changed the O2 sensor as had it plugged in and that was the only problem computer found at time. This didn't do anything

    Also had an injector replaced as this was returning a lot less fuel than the other 3 injectors this made a very small improvement

    Now computer is saying something about swerl flaps but seems like this can't be all that's the problem to me

    ATM the car revs to about 3000 rpm won't go any higher and 40 is max speed with thick white smoke out back. I have also been told that fuel pump is the normal problem but as its thick white smoke I would say poss over fuelling ??

    Any help would be great

    Cheers

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Have you checked the condition of the swirl flap (As thats the code) or cleaned the egr?

  3. #3
    New Member
    Join Date
    Apr 2012
    Location
    Cambridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Egr been cleaned but not had manifold off yet to check swirl flaps. Just can't afford to spend money doing that if it won't fix problems as this error code didnt come up to begin with

  4. #4
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Just take the engine cover off and see if the bar is still attached and if there is oil around the pivot points.

    Also get someone to rev the car and see if number 3 flap moves when rev'ed.

  5. #5
    New Member
    Join Date
    Apr 2012
    Location
    Cambridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Bar was off but was placed back on. The bar moves to begin with till the error code comes up then it stops moving, just really wanted to know if this can cause the problems I'm getting

  6. #6
    Regular Member
    Join Date
    Jul 2007
    Location
    gwent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes it will cause the problem as the swirl flap is sticking as with my own car did a actuator test and the flaps won't close shut and won't open all the way. The last couple of day had a fault code and gone into limp mode cleared fault but has come back car is under power at the moment but drives ok have ordered a new inlet manifold and all the parts to do the job.

  7. #7
    New Member
    Join Date
    Apr 2012
    Location
    Cambridge
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Would this cause the thick white smoke too?

  8. #8
    Regular Member
    Join Date
    Jul 2007
    Location
    gwent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I don't know as my back window is black out but like I said it will cause a lack of power

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. The Vectra C.COM Curse/
    By markone in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 26th December 2011, 15:22
  2. The vectra curse strikes again!
    By byebyeitsagsi in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 5th May 2009, 18:27
  3. Snowflake curse strikes me again !!!
    By FIL 4822 in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 26th March 2008, 17:07
  4. The curse continues
    By DennisTheMenace in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 6th March 2007, 23:31
  5. The curse of ultra blue
    By DennisTheMenace in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 22nd February 2007, 18:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •