User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: slight Loss of power 1.9 cdti 2006

  1. #1
    Regular Member leedrummond's Avatar
    Join Date
    Apr 2011
    Location
    Stoke On Trent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation slight Loss of power 1.9 cdti 2006

    Hi, i am looking for some possible answer / solution to a problem with my dads car

    There seems to be loss of power which i think is so noticable after owning the same car.

    Very noticable when i just took it around the block up hill in second, really struggled felt like i was in wrong gear (4th) nearly had to go up in 1st.

    Could this be a clutch issue or valves leaking ?

    any help appreciated so we can start to fix the problem

    Lee

  2. #2
    Regular Member DeJohnny's Avatar
    Join Date
    Jun 2011
    Location
    belgium
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Have you checked the EGR? Disconnect it for a while and see if its better again, if so buy new egr or fit blanking plate
    Last edited by DeJohnny; 28th April 2012 at 16:01. Reason: typing mistake

  3. #3
    Regular Member
    Join Date
    Jul 2007
    Location
    gwent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It also could be the swirl flap not opening all the way and not closing fully as my car has lost some of it's power but I did have a fault code and did the swirl bar actuator test. I now ordered a new inlet manifold and all the gaskets and new actuator motor all I need now is to sort out finding a garage to fit it

  4. #4
    Regular Member leedrummond's Avatar
    Join Date
    Apr 2011
    Location
    Stoke On Trent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    cheers guys :-) will have a closer look tomorow then and see if its any of these

  5. #5
    Regular Member leedrummond's Avatar
    Join Date
    Apr 2011
    Location
    Stoke On Trent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thank you all that seemed to have fixed it and my dad said his car is getting better by the day. Someone told him to resound it too but he can only do that in 1st gear

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CDTI 150 slight coolant loss
    By AntSSSS in forum Troubleshooting
    Replies: 3
    Last Post: 19th July 2011, 21:34
  2. Replies: 6
    Last Post: 11th March 2011, 21:13
  3. Spanner light and slight loss of power 2.2dti
    By nickd_m in forum Engine & Drivetrain
    Replies: 15
    Last Post: 10th November 2008, 23:28
  4. loss of power 150 cdti
    By SRI-150 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 17th May 2008, 14:24
  5. loss of power 1.9 CDTi
    By ALD in forum Engine & Drivetrain
    Replies: 18
    Last Post: 5th January 2007, 16:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •