User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Help needed on sub woofer set up please....

  1. #1
    Regular Member ridgers84's Avatar
    Join Date
    Jan 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help needed on sub woofer set up please....

    Right. Installed my sub today. It's looking good. I just need to tidy up the wires etc.

    It's sounding good... But it could be better....

    I've got my HPF on my head unit set at 125hz and the crossover on the sub set at around 125hz also - is this correct? The gain is on half way. It's very loud and bassy and over powering but not as punchy as I'd like. I have two ports with removable plugs, if I remove the plugs will that make it more punchy? the sub level in my head unit is on normal.

    Any help appreciated guys

  2. #2
    Regular Member ridgers84's Avatar
    Join Date
    Jan 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ooo... Forgot to add, I'm getting a bit of interference coming through the sub. It's like a clicking sound. Any ideas?

  3. #3
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Trying PM ing Ian Highlander, he seems to be up on car-fi

  4. #4
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    Depends entirely on the setup and your head unit. I generally set the crossover point for subs at about 120hz so you're about right there. But my head unit has a dedicated sub pre output for the sub amps so all my high pass filters are off meaning the speakers in the doors are getting the full range they can cope with which gives a much fuller sound.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  5. #5
    Regular Member ridgers84's Avatar
    Join Date
    Jan 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers Ian. If I turn my filters off I'll have too much bass going through the door speakers and they'll just distort. They've got a punchy mid though! Any ideas what could be causing interference?

  6. #6
    Regular Member Knight Rider's Avatar
    Join Date
    Apr 2008
    Location
    Motherwell
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C SRi 1.8vvti

    Trim : Sri

    Engine : 18.vvti

    Year : 2007

    Mileage : 29,500

    Default

    Is your power cables and speaker cables seperate ie not running along side each other. This could cause interference if they are.

  7. #7
    Regular Member 0114NIGEL0114's Avatar
    Join Date
    Jun 2010
    Location
    SHEFFIELD
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Been looking about to thinking of getting 2x15s there 2000 watts each min 700 rms max 1000 rms what amp do I need I know I need a mono block amp Just looked at a sound storm ev3000d amp not sure though

  8. #8
    Regular Member Guss's Avatar
    Join Date
    Aug 2011
    Location
    West Malling, Kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi ridgers

    your clicking sound is your amp turning on and off away around it is to change your earth, the closer to the amp the better.
    Your sub is cable of putting out much lower than 125 htz, it you can drop it as low as 30 or 40 it will be better, it will push out thundering baxe you feel more than you here.
    your mids will add the puchy bass. If you can drop in a power capacitor 2 million farad variety and your sub will run smoother as it can delivert power quicker than your car battery and ease your alternator which will be put under strain from your amp...

  9. #9
    Regular Member ridgers84's Avatar
    Join Date
    Jan 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by 0114NIGEL0114 View Post
    Been looking about to thinking of getting 2x15s there 2000 watts each min 700 rms max 1000 rms what amp do I need I know I need a mono block amp Just looked at a sound storm ev3000d amp not sure though
    Oi get your own thread! Lol
    Last edited by ridgers84; 27th April 2012 at 21:31.

  10. #10
    Regular Member ridgers84's Avatar
    Join Date
    Jan 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by BLACK KNIGHT View Post
    Is your power cables and speaker cables seperate ie not running along side each other. This could cause interference if they are.
    Hmmm yeah they are, I've got the power cable, remote and output cable all running down the passenger side. Do they need separating then?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help needed
    By justin32 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 31st March 2012, 21:53
  2. Help needed
    By Robward27 in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 22nd March 2009, 01:31
  3. help needed
    By steven_armit in forum General Chat
    Replies: 1
    Last Post: 16th March 2009, 20:05
  4. adding a sub woofer to standard cd30 head unit
    By pogo in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 13th July 2007, 20:53

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •