User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 1.9 CDTI 150 - Issues

  1. #1
    New Member
    Join Date
    Jan 2012
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9 CDTI 150 - Issues

    Dear all,
    I’m new to the forum, had the Vectra since last July.
    I have a Vectra 04 SRI 1.9 CDTI 150, recently been having some issues with it ever since I got it, the latest ones are below.
    Diagnostic machine suggests three codes which I have searched on here and Google but nobody continues thier thread to say whether they have corrected the fault or what they have done.

    I have the following codes on my car:
    P0621 – Generator lamp control circuit malfunction
    P0100
    P0070
    – Ambient air temperature sensor


    The codes were cleared but they keep coming back.
    The car’s idle is very rough and a car with a spanner keeps flashing on the dash intermittently. It also seems to throwing out some smoke on start up. The boost sensor has been cleaned and also the turbo pipes.

    Any help would be appreciated, thanks in advance.
    Edward

  2. #2
    Regular Member
    Join Date
    Jan 2009
    Location
    Chesterfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Im suspecting after market Alternator and Airmass Sensor, anyone agree ?

  3. #3
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Er what colour injector plugs have you got also have you cleane the egr valve out and as above after mafs arnt very good same with tue alternator
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  4. #4
    Regular Member the-wizard's Avatar
    Join Date
    Dec 2007
    Location
    Tamworth - ''The Capital of Mercia''
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra-c

    Trim : sri

    Engine : cdti

    Year : 2004

    Mileage : 98,000

    Default

    you could try cleaning connectors & the maf itself.

    I have the following codes on my car:
    P0621 – Generator lamp control circuit malfunction
    P0100 --P0100 Mass or Volume Air Flow Circuit Malfunction
    P0070 – Ambient air temperature sensor
    Last edited by the-wizard; 27th April 2012 at 17:59.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 cdti 150 eml & EGR & DPF issues
    By carvaletingpro in forum Diesel Engine related
    Replies: 4
    Last Post: 24th August 2012, 08:16
  2. cdti 150 mpg issues
    By Kcs in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 23rd December 2011, 23:44
  3. Issues with CDTI 1.9 SRi 150
    By warren77 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 14th May 2011, 12:12
  4. 3rd injector issues 1.9 CDTi 150
    By @ndy-e in forum Engine & Drivetrain
    Replies: 1
    Last Post: 24th November 2010, 21:21

Visitors found this page by searching for:

p0070 vauxhall signum 2006 19 cdti

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •