User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: vectra top mount bearing question

  1. #1
    Regular Member
    Join Date
    Feb 2012
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra top mount bearing question

    my vectra top mount drivers side is making a noise when you move the steering back and forth do i need to replace all of the bearing or part of it .you can both parts off the internet separately you can get the strut mount and the bearing for £38 do i need anything else .

  2. #2
    Regular Member
    Join Date
    Feb 2012
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






  3. #3
    Regular Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra and a Signum

    Trim : top of the line in both

    Engine : Z18XE,Z19DTH,Z20NET

    Year : 2006

    Default

    you would just need the new bearing not the mount... I did change my mounts as i snapped a stud off in one of them, i then painted up the new mounts as they do corrode before installing them but i would not think you need to replace yours.

  4. #4
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Why not buy this instead, seems better value and a known brand:

    http://www.carparts4less.co.uk/cp4l/...61c8915&000872

  5. #5
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by borderman932 View Post
    my vectra top mount drivers side is making a noise when you move the steering back and forth .
    I thought so with mine too. Turned out just to be small amounts of grit had got between the lower cup and suspension spring stopping it seating properly on the lower cup face. Garage just lifted the spring up slightly with a screwdriver and blew the debris out with an air line, resulting in no more noise.

  6. #6
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Quote Originally Posted by Rebellion View Post
    Why not buy this instead, seems better value and a known brand:

    http://www.carparts4less.co.uk/cp4l/...61c8915&000872
    That's the mount - I think its the bearing itself he needs - I repaired one of my bearings that was a bit rough when turning it. I had taken it off to replace the spring - managed to take it apart cleaned the ball bearings and the tracks they ran in - with a good greasing and its been fine since - worth having a look at it before replacing

  7. #7
    Regular Member
    Join Date
    Jun 2008
    Location
    South east
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by alcutler View Post
    That's the mount - I think its the bearing itself he needs - I repaired one of my bearings that was a bit rough when turning it. I had taken it off to replace the spring - managed to take it apart cleaned the ball bearings and the tracks they ran in - with a good greasing and its been fine since - worth having a look at it before replacing
    No, I've just had a webchat with ECP who run that site and they reckon it comes with the bearing as well.

  8. #8
    Regular Member
    Join Date
    Mar 2009
    Location
    Kildary, Highland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I got Febi Bilstein ones off eBay, bearing only, dead easy to fit - you don't need the mount

  9. #9
    Regular Member david-bell's Avatar
    Join Date
    Sep 2005
    Location
    eastlothian scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra vxr

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2008

    Mileage : 31000

    Default

    I had the same issue as you have! Ireplaced mines with these http://www.eurocarparts.com/suspension-mounting and my mounts were fine I just replaced he bearing hth

  10. #10
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    Quote Originally Posted by david-bell View Post
    I had the same issue as you have! Ireplaced mines with these http://www.eurocarparts.com/suspension-mounting and my mounts were fine I just replaced he bearing hth
    Does the ECP part include the bearing and topmount as one?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. question about front top mount components?
    By MCD in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 11th May 2011, 14:41
  2. Can top mount bearing or arb bushes rattle?
    By MCD in forum Vectra C / Signum Car Chat
    Replies: 28
    Last Post: 18th February 2011, 20:40
  3. Top mount bearing?
    By goafer in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 6th June 2010, 08:57
  4. Wheel Bearing Question ???
    By Cilldara1 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 8th October 2007, 17:03
  5. Astra G Question - Wheel Bearing
    By VectraMat in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 23rd September 2007, 21:34

Visitors found this page by searching for:

vectra c top mount

vectra c top mount bearing

vauxhall vectra vxr top mount bearings

vauxhall vectra suspension top mount

vectra c top strut bearing

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •