User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Replaced fuel filter, now stalls if left to idle.

  1. #1
    Regular Member
    Join Date
    Aug 2009
    Location
    Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Replaced fuel filter, now stalls if left to idle.

    Had my fuel filter replaced on Saturday.
    Previously my 2003 diesel Vectra has run like a dream.
    When I picked the car up from the garage, it took two attempts to start it, with the engine sounding like it was starved of fuel. A bit of accelerator pedal got it going, and it was fine all the way home.
    Before leaving the garage, I pointed this out and was told that it was normal for a new fuel filter, and was assured that it would be fine by the time I'd done a few miles to draw the fuel through. Seemed reasonable to me.

    I've now driven around 45 miles in the car with the new filter but still, when I start it from cold standstill, if I don't drive away immediately it sputters to a stall. Restarting at that point requires some pressing of the accelerator and around 20 seconds of battery cranking. By the time I've traveled 100 metres from cold, it seems to be stable for the rest of the journey, until I get home and leave it for another 8 hours.

    Is this normal? Will it clear up? Or is there something wrong with the filter?

  2. #2
    Regular Member AntSSSS's Avatar
    Join Date
    Sep 2008
    Location
    Middlesex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : SRI

    Engine : CDTI 150 (Z19 DTH)

    Year : 2008

    Mileage : 100k

    Default

    The DTI really needs to be primed with diesel when the filters are changed.. I.e. fill the hosuing with diesel when you re-fit as unlike the CDTI they dont self prime. the problem then comes that all the cranking over with no diesel effects the fuel pump as the diesel has the oils in the pump needs..

    I'd personally want to strip the filter out - check the filter hoses and re-fit filling the housing with diesel...

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default



    These pumps can fail if left to run dry, and 20 seconds of cranking with no fuel could be fatal for it

  4. #4
    Regular Member
    Join Date
    Mar 2011
    Location
    Bulgaria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just yesterday I replaced mine on vectra c 1,9cdti. Just replaced left the car for 30 sec with key in psn II, and start it. Engine didn`t doubt at idle. No problems at all. At least regarding fuel filter

  5. #5
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    The CDTI has a lift pump so by turning the ignition on they prime themselves unlike the DTi's

  6. #6
    North West Regional Organiser paulvectrac's Avatar
    Join Date
    Mar 2009
    Location
    morecambe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    35 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    Two diffent engines as above should of bin hand primed with derv sin a pump fail once when a bloke Down the road was cracking his car over wasn't self bleeding and burnt it out
    Vectra vxr custome remaps egr deletes dpf and diagnostic work all remaps are custome bench tuning avalible all genuine equipment PM for info

  7. #7
    Regular Member
    Join Date
    Jul 2009
    Location
    Brighton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Take it back to the garage where you had the work done. Complain (politely), but give them the chance to rectify it.
    Good luck.

  8. #8
    Regular Member poves's Avatar
    Join Date
    Dec 2007
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    "normal for a new fuel filter, and was assured that it would be fine by the time I'd done a few miles to draw the fuel through."
    lmao - Sound like idiots to me mate .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. When fuel light comes on, how much fuel is left?
    By inchy1981 in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 16th November 2012, 23:32
  2. Replies: 19
    Last Post: 30th May 2012, 15:53
  3. Replies: 22
    Last Post: 22nd September 2011, 14:22
  4. Fuel Consumption while idle?
    By TheWildHaggis in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 17th April 2008, 20:53
  5. Pollen filter replaced!
    By SirGSi in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 23rd September 2006, 05:13

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •