User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Indicator problem when turning

  1. #1
    New Member
    Join Date
    Sep 2010
    Location
    Norway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Indicator problem when turning

    Sorry for my lazy google translate from norwegian

    I have a problem on my 05 Vectra C 1.9 CDTI 150 BHP.
    When I flash to one side at a traffic light and correct wheel does not stop blinking lights on the left before I have swung slightly to the right of the steering wheel.

    When I flash to the right of a traffic light and straightens the steering wheel the indicator stops before i have straighten the wheel completly
    It seems to me that a sensor that knows when the wheel is in the center is not working properly and is slightly misaligned to the left.

    The turning light on the left also turn on where easy when i turn just a little bit in low speeds.

    Thanks for some information here and maby what i can try.

  2. #2
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    I had a similar problem with non cancelling left indicators sorry to say it was the CIM (electronic module on the steering column) which is not cheap

  3. #3
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Can the steering angle just be reset or re-calibrated?
    Now I need a turbo to keep up!

  4. #4
    New Member
    Join Date
    Sep 2010
    Location
    Norway
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    Can the steering angle just be reset or re-calibrated?
    Somebody know if this is possible?

  5. #5
    New Member
    Join Date
    Jun 2011
    Location
    Milan
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Maybe I solved dismounting CIM and cleaning all contacts. After I dismounted all, steering wheel, airbag,... I removed the original white oxidation paste, cleared all printed circuit board tracks (paste near light indicator tracks were very dirty) and scratched with a pen rubber.
    Then I replaced anti oxidation paste with normal vaseline paste, for automotive battery, and remounted all.
    Since two weeks I haven't any problem.
    Pay particular attention during CIM dismounting to avoid pin contactors flexure.

    Sorry for my english... translated by myself from italian....

    You can find a complete procedure here in italian.
    Rod

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intermintant problem with not turning over
    By kieronh84 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 20th February 2013, 23:14
  2. Rear indicator problem
    By dods84 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 4th July 2012, 01:02
  3. indicator problem
    By jamie226 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 18th February 2011, 08:01
  4. weird indicator problem
    By geebee007 in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 16th March 2010, 10:45
  5. Problem when turning engine off!
    By user999998 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 17th June 2008, 01:25

Visitors found this page by searching for:

vauxhall vectra 2006 1.9 cdti indicator problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •