User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Traction control sorted! Read this if you've got problems

  1. #1
    Regular Member Dai69's Avatar
    Join Date
    Feb 2010
    Location
    Nr Welshpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking Traction control sorted! Read this if you've got problems



    The TC & ABS lights came on the other day and I finally got chance to check it out today, so I plugged the car in & found fault codes for both front sensors!! But worse than that it also said there was a comms error with the ABS module

    I checked the fuses and they were okay.

    I've had problems with the ABS in the past and have done away with the plugs at the back of the arches which always corrode due to the water ingress; so I checked the plugs on the struts and they are fine.

    The sensors on the Vec are of the active or "Hall effect" type so need a supply to them, so I checked this next and found that there was no power to the offside front!

    I'd already checked the ABS fuses were okay so I checked the connections onto the ABS module next and they are all okay as well. I plugged the module back in then and took the top off the plug to access the cables. Using a small probe on my test lead I then checked for voltage going out and found that one channel was down on the module giving no reference voltage out to the front right wheel sensor.

    Not to be beaten, I stripped the insulation back on that wire and the reference voltage wire for the other front wheel sensor and have now soldered the two together.

    WHOOP WHOOP The warning lights have gone out and the fault codes have all reset! RESULT!

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)

    Default

    So you have joined the left and right speed sensor wires together?

  3. #3
    Regular Member Dai69's Avatar
    Join Date
    Feb 2010
    Location
    Nr Welshpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Only the reference voltage wires. Not the signal wires or it would just be tricking the ABS/TC in to thinking that both wheels are running at the same speed and it wouldn't work!!!! By only connecting the reference voltage wires together the one channel is supplying both sensors with the required voltage and both sensors are giving their own signals back, so the ABS & TC work perfectly!!

  4. #4
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Default

    Whereabouts is the abs module located?.....

  5. #5
    Admin & Server Techy Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Post Thanks / Like
    Mentioned
    53 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    53 Post(s)
    Tagged
    0 Thread(s)

    Default

    Under the bonnet behind the battery box.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  6. #6
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Default

    Appreciate the quick response..does it sit behind the block with all the brake lines going into it?

  7. #7
    Regular Member Dai69's Avatar
    Join Date
    Feb 2010
    Location
    Nr Welshpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yeah, that's the one

  8. #8
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Default

    ahh...im trying to sort the eratic on/ff abs/traction control light problem..never had a problem till i changed the rear wheel bearings 6 months ago BUT cant see any issues with the wiring ..hummm..am also looking for the fuses/relays...

  9. #9
    Regular Member Dai69's Avatar
    Join Date
    Feb 2010
    Location
    Nr Welshpool
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by nikroc View Post
    ahh...im trying to sort the eratic on/ff abs/traction control light problem..never had a problem till i changed the rear wheel bearings 6 months ago BUT cant see any issues with the wiring ..hummm..am also looking for the fuses/relays...
    ABS fuses are located in the engine bay fusebox.....can't remember the numbers but 2 of the large ones supply the ABS module. Easy to check them as there are test points on the top of the fuses Only a 2 minute job to check them all.

  10. #10
    Regular Member nikroc's Avatar
    Join Date
    Nov 2007
    Location
    DERBY
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    12 Post(s)
    Tagged
    0 Thread(s)

    Default

    Appreciate the heads up..all checked,all good...******

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. traction control
    By jpbroad1970 in forum Vectra C / Signum Car Chat
    Replies: 36
    Last Post: 24th April 2012, 11:23
  2. 2 problems - 1 sorted and 1 question..
    By Steven in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 1st November 2010, 15:07
  3. Problems mostly sorted but tyres....
    By stevea1234 in forum Insignia Chat (READ ONLY)
    Replies: 8
    Last Post: 29th January 2010, 01:30
  4. Traction control
    By hot-vec in forum Vectra C / Signum Car Chat
    Replies: 34
    Last Post: 7th April 2006, 12:00
  5. Gearbox Problems 6 Speed - Sorted.
    By The Doc in forum Engine & Drivetrain
    Replies: 0
    Last Post: 12th December 2005, 14:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •