User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: 06 1.9 sri 150 66k

  1. #1
    New Member
    Join Date
    Dec 2010
    Location
    Newcastle Upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 06 1.9 sri 150 66k

    Hi all

    I was driving home yesterday when I went to pull away I had little to no power No EML on . The car then picked up and seemed okay but was very sluggish in 1st nd second gear .

    I have gone to drive it today and the car seems to have no revs when I press the peddal, it starts but no revs. I have been reading and wonder if this could be the EGR valve being kyboshed or something more serious.

    any ideas has anyone had this happen.

    cheers

    Lee

  2. #2
    Moderator & Events Assistant paulhb's Avatar
    Join Date
    Dec 2007
    Location
    Wondering lonely as a cloud
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    24 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : M5

    Trim : Nothing needs adding

    Engine : 5.0 V10

    Year : 07

    Mileage : 37000

    Default

    Get your EGR off and give it a clean up make sure the valve opens and shuts freely, clean the boost sensor whilst you are at it.

  3. #3
    New Member
    Join Date
    Dec 2010
    Location
    Newcastle Upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Paul will give that a try I was just not sure if this sounded like a EGR or not.

  4. #4
    Regular Member
    Join Date
    Dec 2006
    Location
    kirriemuir
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thats what i had when my egr was knackered no revs then pulled higher up the revs once it got there

  5. #5
    New Member
    Join Date
    Dec 2010
    Location
    Newcastle Upon Tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the reply slugo yeah thats what happened then tonight simply no revs the joys of motoring .

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •