User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 1.8 SRi 57 plate ignition struggle

  1. #1
    New Member mossy_46's Avatar
    Join Date
    Apr 2012
    Location
    Ipswich
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default 1.8 SRi 57 plate ignition struggle

    Hey all, I'm new here and needing some ideas. When I try to start my Veccy, most times it is perfectly fine, but occasionally it will struggle, all lights go off the dash except battery light, it struggles, then starts, but all displays seem like they hav had a reset, although CD plays from same place it left, time is ok, etc, but temperature has disappeared and then comes back after a couple of seconds. On some occasions it displays turn lamp signal but the lights all work fine. I am confused by this issue and concerned as to what it may be. I have checked all fuses, and just had a service done anyways, new plugs, oil n filter, fuel filter and air filter. Had new coil pack last year August time.

    Please suggest ideas for me to investigate. Thanks in advance all who can help.

  2. #2
    Regular Member
    Join Date
    Dec 2011
    Location
    Woking
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Try the spare key in case it's the imobiliser chip in the key

  3. #3
    Regular Member
    Join Date
    Oct 2008
    Location
    rothwell leeds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    firstly i would check and clean all battery connections inc earth to body and starter motor, next check the battery with a multimeter then with it still connected to battery take some readings when cranking over they should have a series of simular readings if you have a odd reading every now and then it could be down to a worn segment in the starter motor causing an excessive draw from the cranking amps of the battery;i have seen this on many fiats over the years causing simular dial problems.. HTH

  4. #4
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)

    Default

    i would get the battery and alternator checked fella see what levels are on the battery and what charge the alternator is throwing out then id check and clean the abs plug under the bonnet sometimes this makes the dash go funny etc
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No ignition
    By pud wayman in forum Electrical & ICE (including SatNav)
    Replies: 15
    Last Post: 12th December 2011, 01:26
  2. Struggle to start when cold and cloud of smoke
    By MattHD in forum Engine & Drivetrain
    Replies: 23
    Last Post: 25th July 2011, 17:06
  3. Tips on using the forum for ppl who struggle
    By azacbr6 in forum The 'Off Topic' room
    Replies: 4
    Last Post: 8th May 2011, 09:42
  4. The struggle to fit my HID kit
    By luke4487 in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 20th December 2010, 17:55
  5. rear number plate lights on all time when keys in ignition
    By shearzy in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 19th April 2010, 13:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •