User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Display

  1. #1
    New Member
    Join Date
    Feb 2011
    Location
    BEDFORDSHIRE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Display

    Hi

    I have a 2006 CDTi SRi and the display fan has a permanent clicking noise when it kicks in.

    It sounds like the fan blade is hitting a wire or fouling something. It works okay it's just annoying.

    Has anyone had experience of this or can tell me how to get the display out to investigate?

  2. #2
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    not sure what you mean about display fan fella
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  3. #3
    New Member
    Join Date
    Feb 2011
    Location
    BEDFORDSHIRE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Display

    Sorry, I mean the central sat nav colour LED screen.

  4. #4
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    the colour screen has a fault?
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  5. #5
    Regular Member cossie's Avatar
    Join Date
    Mar 2006
    Location
    MANCHESTER
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I thought you were talking about the heater fan. If you are - The fan is behind the glove box - I dont think (although I stand to be corrected) you need to take the display/vents out - just remove the glove box and the heater blower housing is located under there in the passenger footwell.

    If you do need to remove the display and centre vents, the trim panel (colour and style dependant on trim level) is easily pulled off (make sure you do it evenly so as not to snap it) revealing four torx screws holding the whole centre panel in - here is a pic with it all removed if it assists you

  6. #6
    New Member
    Join Date
    Feb 2011
    Location
    BEDFORDSHIRE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the info.

    It is the display between the two central vents. I think this is where the noise is coming from (or possibly the radio. It's not the heater fan).
    The noise/fan is only heard on hot days and only comes on after a while i.e. when the display has obviously got hotter.

  7. #7
    Full Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    Are you VXR Enough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXR8 6.0 muscle SRI ESTATE XP1

    Trim : VXR/ SRI ESTATE CDTI XP1

    Engine : 6.0 V8 Thunder

    Year : 2008

    Default

    the display dosnt have a fan fella. the head unit i dont think has one either maybe its the cd drives in the head unit?
    VXR IS FOR LIFE NOT JUST FOR THRILLS !



  8. #8
    Regular Member kenp's Avatar
    Join Date
    Feb 2008
    Location
    Kr. Hyllinge, Denmark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C


    Engine : 2.2 Direct

    Year : 2004

    Default

    Spinds more like the fan in your radio that have problems

  9. #9
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    There's no fan on the screen fella. It's possible if you've fitted an aftermarket radio THAT has a fan in it (I've seen a few that do), but none of the standard ones do, it could be the CD mechanism in the radio got a tooth gone on a drive cog.

    It's could also be the recirc cogs in the main fan unit or something.

    Alternatively you've got an electrical short somewhere that's arcing (can sound the same sort of noise) in which case I'd rip it all out quick and check it because that could start a fire if it's the case.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  10. #10
    New Member
    Join Date
    Feb 2011
    Location
    BEDFORDSHIRE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's definitely some sort of fan. When it cuts out you can hear the fan slowing down.
    The car has the standard head unit. So perhaps it's the radio. I'll have to visit halfords and get the kit pull it out.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replacing Board Info Display (BID) with Color Info display (CID)
    By grigs1 in forum Electrical & ICE (including SatNav)
    Replies: 49
    Last Post: 11th April 2012, 22:13
  2. mp3 on display
    By marc vectra sri in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 27th August 2011, 14:54
  3. PS3 display
    By @ndy-e in forum Games Room
    Replies: 2
    Last Post: 27th December 2010, 08:21
  4. temp display on radio display
    By MRunMotorsport in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 19th April 2010, 15:55
  5. LED DIsplay
    By dcraigen in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 18th September 2008, 10:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •